Multiple DNS Addresses in FOG_PXE_IMAGE_DNSADDRESS



  • Hi there,

    is there a way to use multiple DNS-Addresses in the FOG_PXE_IMAGE_DNSADDRESS. I have i FOG Server running, using 2 NICs on 2 different networks. There is no link between them despite of the FOG Server. To use the FOG server on both networks I set up an BIND DNS server which translates the hostname of the FOG Server to different IPs depending on the subnet asking. Problem now is, that on the first network the DNS/FOG Server address is the 192.168.0.1, on the second network its 192.168.1.1. FOG now starts the Job, but when the next access to the TFTP is required it won’t find it. Now it would be perfekt to be able to use 2 DNS Server addresses so that the one beloning to the used network and NIC answers the request and gives me the right IP address fot the TFTP.

    Thanx for your help,

    Marcel



  • @Tom-Elliott

    Ok so you would recommend switching to the latest version from the trunk of the repo? I will try that tomorrow.

    Yes, I exchanged all the IP addresses with hostnames because my FOG server has different IP addresses depending on the NIC the client is connected to. I think it will work once the dns system works properly with the dns server address provided by the DHCP server.

    I keep you updated when I tried with the latest version.

    Thanks
    Marcel


  • Senior Developer

    @mpinnow 1.2.0 did not have an auto recognizing dns system so the dns records were always added via the FOG_PXE_IMAGE_DNSADDRESS. This is fixed in trunk and it automates this issue altogether.

    Are you calling the storage/server via hostname in the configurations? I can only think that it’s failing because it can’t resolve the hostnames if that’s the case.



  • Hi Tom,

    thank you for your reply. We’re running fog 1.2.0.

    Maybe I’m looking at the wrong point trying to fix the error I currently experience. Situation atm is, when i try to do a Hardware Inventory task on a client i get as far as:

    Attempting to register host…

    then it starts to scroll down the screen with one line per second until the screen is all black. I changed the iFOG_USE_SLOPPY_NAME_LOOKUPS to “no” (no tick set) and defined the needed dns on FOG_PXE_IMAGE_DNSADDRESS to 192.168.1.1 and it worked. Prolem now is, that i would need a second dns entry for the other network on the other NIC. Do you know any workaround, or why it fails to register the host without the dns entry? My DHCP Server supplys a DNS address when assigning the IP to the client.


  • Senior Developer

    What version of fog?

    Currently, no there is no way, but we also no longer need this field as the init’s will get their DNS Servers from the DHCP request as well.


Log in to reply
 

396
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.