FOG Compatibility Test Failed



  • Hi,

    When I run “Check FOG Compatibility” on a client.

    I get -
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    Results

    Network …[ Pass ]
    Disk …[ Fail ]

    Try using a newer kernel that may be compatible with this device.
    New kernels can be downloaded with the “Kernel Updater” in the FOG management interface.
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    I downloaded newer Kernels. 3.19.3 and 3.1-rc8.

    When I use 3.19.3, I get same above error. When I use 3.1-rc8, I get the kernel panic error and I do not even reach to the menu to select “Check FOG Compatibility”.

    The client machine is already installed with an OS, this OS uses a customized kernel file. I believe, I am getting this error because of incompatible kernel. So I tried to use “vmlinuz” customized kernel file (taken from running client machine) for compatibility test. But I got the kernel panic error again (image attached).
    0_1453880477576_FOG_vmlinuz_3.1.10-gb16-default_compatibilityFailure1.png

    Not sure how to proceed further. Any help is much appreciated.

    Thank you.



  • @Wayne-Workman I believe that would be a right thing to do.


  • Moderator

    @Tom-Elliott @techlover28

    What’s wrong with this line?
    range dynamic-bootp 192.168.1.253 192.168.1.254;

    I would recommend we add 10 to the network base (in the ConfigureDHCP function) instead of 253.



  • @Sebastian-Roth @Sebastian-Roth Yes it is with “option subnet-mask”. But install.sh is still failing.

    A quick question, do “ldap” errors won’t affect the working of DHCP? I can ignore it then.

    @Quazz Please find the output below:

     # dhcpd -t -cf /etc/dhcp/dhcpd.conf
    Internet Systems Consortium DHCP Server 4.1.1-P1
    Copyright 2004-2010 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
    

    @Wayne-Workman Please find the complete DHCPd.conf below:

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.1.1;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 192.168.1.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 192.168.1.253 192.168.1.254;
        default-lease-time 21600;
        max-lease-time 43200;
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
            filename "ipxe.efi";
        }
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
            filename "undionly.kkpxe";
        }
    }
    

  • Moderator

    @techlover28 Can we see your entire dhcpd.conf file please?

    Also, dhcp ignoring interface em1 is fine, since you don’t want dhcp served on that network.
    But if you want that error to go away, just create a blank declaration for that interface’s network.


  • Moderator

    With option subnetmask included, could you run

    dhcpd -t -cf /path/to/dhcpd.conf
    

    And post the output here? (or on pastebin if it’s a lot)


  • Developer

    Is this with “option subnet-mask”?? Looks ok from the logs I reckon:

    Feb  4 15:30:18 Phoenix dhcpd: Listening on LPF/em2/f8:bc:12:3b:48:3d/192.168.1.0/24
    Feb  4 15:30:18 Phoenix dhcpd: Sending on   LPF/em2/f8:bc:12:3b:48:3d/192.168.1.0/24
    


  • @Sebastian-Roth Ah! sorry. Behavior has changed from the previous versions. In previous version, it used to say “unrecognized command” or something (not sure about the exact errors) in messages.

    But in the current version (6181), install.sh does fail on DHCP but not because of “options” thing. Should be something else. It doesn’t give the same error under messages which it used to in old version.

    In fog_error_6181.log, we see this:

    Shutting down dhcpd: ESC[60G[ESC[0;32m  OK  ESC[0;39m]
    Starting dhcpd: ESC[60G[ESC[0;32m  OK  ESC[0;39m]
    status: unrecognized service
    

    In messages, we see this:

    Feb  4 15:30:18 Phoenix dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
    Feb  4 15:30:18 Phoenix dhcpd: Wrote 0 class decls to leases file.
    Feb  4 15:30:18 Phoenix dhcpd: Wrote 0 leases to leases file.
    Feb  4 15:30:18 Phoenix dhcpd: Listening on LPF/em2/f8:bc:12:3b:48:3d/192.168.1.0/24
    Feb  4 15:30:18 Phoenix dhcpd: Sending on   LPF/em2/f8:bc:12:3b:48:3d/192.168.1.0/24
    Feb  4 15:30:18 Phoenix dhcpd: 
    Feb  4 15:30:18 Phoenix dhcpd: No subnet declaration for em1 (10.201.6.176).
    Feb  4 15:30:18 Phoenix dhcpd: ** Ignoring requests on em1.  If this is not what
    Feb  4 15:30:18 Phoenix dhcpd:    you want, please write a subnet declaration
    Feb  4 15:30:18 Phoenix dhcpd:    in your dhcpd.conf file for the network segment
    Feb  4 15:30:18 Phoenix dhcpd:    to which interface em1 is attached. **
    Feb  4 15:30:18 Phoenix dhcpd: 
    Feb  4 15:30:18 Phoenix dhcpd: Sending on   Socket/fallback/fallback-net
    Feb  4 15:35:50 Phoenix dhcpd: Internet Systems Consortium DHCP Server 4.1.1-P1
    Feb  4 15:35:50 Phoenix dhcpd: Copyright 2004-2010 Internet Systems Consortium.
    Feb  4 15:35:50 Phoenix dhcpd: All rights reserved.
    Feb  4 15:35:50 Phoenix dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    

    It appears to be a system specific issue. I should be able to get rid of it soon.


  • Developer

    @Quazz Thought about that too, but tested with and without space and it’s fine either way.


  • Moderator

    @techlover28 That should not cause an issue, but I do note that in my dhcp configs there’s a space between netmask 255.255.255.0 and {

    Might be irrelevant, but I’ve yet to see a valid config without that space.


  • Developer

    @techlover28 Please take a look at your syslog while having the option in place and restarting dhcpd. Do tail -f /var/log/messages on one console and restart the service on another. See what error message comes up.



  • @Sebastian-Roth I am not sure why it is causing the issue. When I remove it, DHCP service works, when I keep it, DHCP service does not come up.

    May be because we are configuring mask (255.255.255.0) two times?


  • Developer

    I have that option in my config too. Does not cause an issue?! I can’t see what’s wrong with it.



  • @Sebastian-Roth Thank you for the instant response.

    I have edited it and removed the “$” symbol.

    It has failed again.

    Setting up and starting DHCP Server…Failed!

    It seems that “dhcpd.conf” has the “option subnet-mask 255.255.255.0;” line in it. When I remove it, I am able to start the DHCPd service.

    subnet 192.168.1.0 netmask 255.255.255.0{
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 192.168.1.253 192.168.1.254;
    default-lease-time 21600;
    max-lease-time 43200;

  • Developer

    Sorry! Should be (remove $):

                [[ -z $submask ]] && submask=$( cidr2mask $(getCidr $interface))
    

    @george1421 You are absolutely right about people need to get enough sleep!



  • @Sebastian-Roth I have edited functions.sh file - replaced 1705 line.

    I am facing the same issue again.

    Setting up and starting DHCP Server…/lib/common/functions.sh: line 1705: =255.255.255.0: command not found
    Failed!


  • Developer

    @techlover28 No I think there is a fix needed that @Wayne-Workman can shoot up pretty soon!

    In line 1705 instead of:

                [[ -z $submask ]] && $( cidr2mask $(getCidr $interface))
    

    should be (I reckon):

                [[ -z $submask ]] && $submask=$( cidr2mask $(getCidr $interface))
    

    You can edit this in your local files and test till you hear from Wayne.



  • I am trying to make an understanding with GIT and going to try again installing version 6181 after setting GIT up.



  • @Wayne-Workman Sorry I should have downloaded and installed it instead of just looking at the text. I have downloaded it and trying to install it now.

    I am getting an error:

    Setting up and starting DHCP Server…/lib/common/functions.sh: line 1705: 255.255.255.0: command not found
    Failed!

    I think it should be something to do with GIT.


  • Moderator

    @techlover28 Please update and try again, the changes I’ve made have been merged. Maybe it’s fixed now?


Log in to reply
 

435
Online

38994
Users

10714
Topics

101705
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.