TFTP Open Timeout



  • Hi Guys,

    Our XenServer recently went down and when it came back up, I thought my FOG server was good, but when I try to PXE Boot, it throws an PXE-E32: TFTP Open Time Out.

    Here’s a bit about the server and what I’ve tried.

    • Ubuntu 14.04 Desktop
    • FOG Server 1.2
    • It is on static, 192.168.x.x
    • DHCP Server is PF Sense, I did double check to make sure that it allows network boot under the correct VLAN and made sure that the IP and file name is correct
    • when I try to get the file on windows tftp -i 192.168.42.5 get undionly,kpxe the output is > tftp: can’t write to local file ‘undionly.kpxe’
    • so I tried to run cmd as an administrator, and when I do that it throws Connect Request Failed
    • I can access the server via web GUI
    • I tried cp /tftp/undionly.kpx /tftp/undionly.0, restarted the server, nothing

    Let me know if there’s something else I should try or look?



  • so I went ahead and tried sudo service tftpd-hpa restart and waited a few minutes. then tried to PXE boot and it worked. However, instead of registering the host, I inputted the MAC address thru the WEB GUI.



  • Hi @Tom-Elliott

    The GUI came back, but I’m still unable to PXE boot. still getting a timeout error.


  • Senior Developer



  • Hi Tom,

    I did that, now when I try to access it thru the WEB GUI it prompts me to update. Once I press on that, I get Update/Install Failed!

    Also, when I try to PXE boot, the error I get is Could not boot: No such file or directory (http://ipxe.org/2d12603b)


  • Senior Developer

    Try manually restarting the tftpd-hpa service:

    sudo service tftpd-hpa restart


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.