Snapin failing to download



  • I’ve successfully made a couple of snapins, including one for Intel video drivers. However, a snapin that I’ve made for NVidia video drivers just won’t download. I get the following messages:

    4/23/2012 3:54 PM FOG::SnapinClient Attempting to connect to fog server…
    4/23/2012 3:54 PM FOG::SnapinClient Module is active…
    4/23/2012 3:54 PM FOG::SnapinClient Snapin Found:
    4/23/2012 3:54 PM FOG::SnapinClient ID: 10
    4/23/2012 3:54 PM FOG::SnapinClient RunWith:
    4/23/2012 3:54 PM FOG::SnapinClient RunWithArgs:
    4/23/2012 3:54 PM FOG::SnapinClient Name: NVidia Drivers
    4/23/2012 3:54 PM FOG::SnapinClient Created: Apr 23, 12
    4/23/2012 3:54 PM FOG::SnapinClient Args:
    4/23/2012 3:54 PM FOG::SnapinClient Reboot: No
    4/23/2012 3:54 PM FOG::SnapinClient Starting FOG Snapin Download
    4/23/2012 3:54 PM FOG::SnapinClient Failed to download file.
    4/23/2012 3:54 PM FOG::SnapinClient The remote server returned an error: (500) Internal Server Error.
    4/23/2012 3:54 PM FOG::SnapinClient at System.Net.WebClient.DownloadFile(Uri address, String fileName)
    at FOG.SnapinClient.startWatching()

    over and over again. I’ve tried deleting and re-creating the snapin; that didn’t help. I’ve already changed php.ini to allow for downloads up to 1900M, so that’s not the problem. Does anybody have any other ideas?



  • Aha! I figured it out.

    My FOG server is running on CentOS, so I used the instructions for Fedora to modify php.ini. However, apparently under CentOS, you must also modify the memory_limit setting, similar to Ubuntu, or large snapins will fail. I’m surprised my Intel video snapin worked.

    Regardless, once I modified memory_limit to 1900M, the snapin downloaded. Sweet!


Log in to reply
 

413
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.