Deploy only working with the original machine... Why??



  • Hi,

    Iḿ trying FOG with the server on a ubuntu 11.10 and imaging machines with ubuntu 11.10 EXT3. Everything works fine, the upload and the deploy, but the image deploying only works on the machine that the original image was uploaded. I can’t figure out what could be the problem.

    My impressions about the software are the best, great sofware, congratulations.

    Troy



  • Updating,

    Two very importante things that I’ve experienced:

    • Wipe the disk before the image
    • Run FSCK if the image is not uploading properly

    Now seems to be working well in all hardwares.

    Thanks!

    Troy



  • Xibeaga,

    the boot order remains correct, and teh NIC is eth1.

    I’m testing Ubuntu 12.04 LTS today single boot ext3 and no success, it’s getting hard to continue.

    Troy



  • you must enter the BIOS by pressing “DEL” or something at power-up and then reorder the boot-devices,
    that means for example: boot from PXE, CD, Harddisk

    The NIC-Names: after cloning open a shell and enter “ip add” or "iconfig"
    then you can see som config stuff, a few lines will begin with “eth0” or “eth1” or “eth12”. these are the names i am asking for.
    NIC = Network Interface Card

    Thanks!



  • Hi Xibeaga,

    thank you again, how can I reconfigure the bios sight? I don’t know what this mean for sure. And the NIC-names that you want, tell me more about how get this so I can post to you.

    Troy



  • tell me ur NIC-names (the names of the Ehternet-Interfaces) - I would really like to know if this works or not



  • Hi!
    I experienced this problem too.
    It happens always to the SAME machine at my site.
    This machine “forgets” - no idea why - the BIOS-Boot-Order and drops the harddisk off the bootlist.
    It does this ALWAYS after cloning. ;)
    So, i just reconfigure the BIOS sigh .
    Maybe this happens at your site too.
    xibeaga



  • Oh boy!!!

    Another issue,

    I’m testing now 4 machines with identical hardwares:

    • Upload the image of the machine 1 - OK

    • Deploy the image of the machine 1 on machine 1 - OK

    • Deploy the image of the machine 1 on machine 2 - OK

    • Deploy the image of the machine 1 on machine 3 - OK

    • Deploy the image of the machine 1 on machine 4 - No Go!! Boot looping

    4 machines with Identical hardwares, how could this be possible??

    Using Ubuntu 11.10 with ext3

    Troy



  • Great! :)

    Did u verify the NIC-Names? I had eth11 and higher on the clones with ubuntu 11.10 and suse12.1
    so i reconfigured the udev stuff

    xibeaga



  • Hi Xibeaga,

    thank you very much,

    I have good news, the problem appear to be solved. The only change I’ve made was in the type of the partitions, for the ubuntu 11.10 ext3 primary, and for the swap instead of logical a PRIMARY PARTITION. After this changes I can image different machines and with different hardwares too. Wonderfull!

    troy



  • 2 troy again:

    in /boot/grub/menu.lst there are lines like:

    kernel /boot/vmlinuz-3.1.10-1.9-desktop root=/dev/disk/by-id/ata-ST9320423AS_5VH5W2C7-part3 resume=/dev/disk/by-id/ata-ST9320423AS_5VH5W2C7-part4 splash=silent quiet showopts vga=0x367

    change them to:

    kernel /boot/vmlinuz-3.1.10-1.9-desktop root=/dev/sda1 resume=/dev/sda1 splash=silent quiet showopts vga=0x367

    replace /dev/sda1 by your partition number

    if u use some “pseudo-beautified” distro like Ubuntu u might have to change this line somewhere else and reconfigure grub.
    But be careful, the auto-reconf of grub will put the OLD value in place of your partition-name. So finally you will end up changing the file /boot/grub/menu.lst which says somewhere in a comment “do not touch me”

    if u want to have my script to reconfigure your NICs, let me know, I am back in my lab tomorrow.

    greets,
    Xibeaga



  • Hey Troy!

    I know your problem!

    to be precise: you have got 2 problems.

    1. Bootloader

    2. udev

    3. is simple:
      the NAME of the disk does not exist on the other machines, so u must not boot off that disk
      solution:
      in grub-config: replace the NAME of the boot-disk with its real partition name

    4. is a f*cking heck!
      i did not manage to solve it really satisfying up to now.

    at install time the NICs get bound in into the udev config with the mac adresses.
    so, things get srewd! when you got past problem 1) aou will see these Nics on the non-masters
    eth11, eth13,… aaargh!

    so: u must replace the mac adresses in the udev-config with those which are really present.
    i wrote a script for that. what that script does is simple:
    a) it checks if the script has already been started, if yes it terminates
    b) it replaces all the MACs in the udev config stuff ( i have 3 MACS per PC)
    c) it reboots to let the kernel get known of the new macs

    Unfortunately it does not work to 100%, just 90%. I have no idea.
    Maybe there is a bug in my script.

    Greets,
    Xibeaga



  • Hi Raff,

    The FOG server is running on ubuntu 11.10, and the OS that I am trying to image is ubuntu 11.10 too. The version of FOG server is 0.32

    This is what I did:

    • Uploaded an image from a machine running ubuntu 11.10, single disk, multiple partitions, succesfully

    • Deploy this image in two machines with identical hardwares, one of this machines is the same that I uploaded the image (this is for testing purposes only).

    • The machine 1 (The machine that I previously uploaded the image from) works well, but the machine 2 stucks with a black screen after exiting the pxe menu. I’ve tried this two times with no success for the machine 2.



  • We need more info, Whats the operating system, does the computer boot, and error message? If I had to guess on the info you provided I would guess its windows 7 and you didn’t run fogprep, sysprep.


Log in to reply
 

426
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.