How to change webui passwords w/o using webui



  • Hello all,

    I am trying to figure out where FOG stores it’s usernames and passwords. I am working on a tftp issue and for some reason can NOT log in to the web UI. I’ve tried every possible combination that it could be and still no luck. I found the following, but it didn’t help:

    [url]http://fogproject.org/wiki/index.php?title=Reset_WebUI_FOG_password[/url]

    Anyone have any ideas or know which file stores them so I can manually edit them? Thank you for your time!



  • Glad you figured it out. :)



  • That did not work either, but the problem has been solved! Thank you very, extremely, much for helping me try to figure this thing out. It turns out somehow the only user we had in the database was [U]NOT[/U] the admin for some reason, my friendly neighborhood programmer found that issue and resolved it.



  • [FONT=Arial][COLOR=#111111]Try the below. I would also look at “/var/www/fog/commons/config.php” and “/opt/fog/service/etc/config.php” to make sure your mysql info is defined. Since fog uses MySQL, the user and passwords are stored there. You can also install “phpmyadmin” and see if your fog user is there. If you can log into root, you should be able to change the password and assign permissions to that user.[/COLOR][/FONT]
    [LIST=1]
    [][FONT=Arial][COLOR=#111111]mysql -u root -p[/COLOR][/FONT]
    [
    ][FONT=Arial][COLOR=#111111]mysql> use mysql;[/COLOR][/FONT]
    [*][FONT=Arial][COLOR=#111111]mysql> update user set password=PASSWORD(“NEW-PASSWORD-HERE”) where User=‘fog’;[/COLOR][/FONT]
    [/LIST]



  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • I did as you said and received this in response:

    mysql> UPDATE users SET uPass = MD5(‘password’) WHERE uName = ‘fog’;
    Query OK, 0 rows affected (0.00 sec)
    Rows matched: 1 Changed: 0 Warnings: 0

    I tried logging in using fog as the uname and password as the passwd and nothing happens. It doesn’t log in or give me an error, just reloads the log in page basically. Is there no way to manually edit these files without going through the terminal or mysql?



  • This post is deleted!


  • This post is deleted!


  • “sudo” basically means run as root under this user. If you only used “sudo mysql” it should ask you for a root password. I would use the command “mysql -u root -p” to log into root and then try the link you posted.



  • [quote=“sam-white, post: 2993, member: 118”]Have you tried logging into MySQL using root and changing the password for the fog user?[/quote]
    The link I have in my post is the method you are speaking of isn’t it? If not then no, I haven’t.



  • This post is deleted!


  • Have you tried logging into MySQL using root and changing the password for the fog user?


Log in to reply
 

423
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.