FOG gui log out even if option is set to no

  • I have turned the option in FOG settings, login setting, FOG_ALWAYS_LOGGED_IN to ON. I’m still logged out after a period of inactivity.

  • I think I had this problem with fog 0.32 also. Does fog stay logged in when you let a tab with the logged in fog home screen (with the graphs) run all the time and open new/other tabs for working with fog? (Didn’t monitor fog 1.2 and svn versions for this problem yet)

  • @Tom-Elliott No, I run gui from the same host all day long. The host has a fixed ip address. I have no problem staying alive at sites like joomla, limesurvey etc which runs on the same centos server. I can do some research to see for how long I stay alive without activity.

  • What?

    Ubuntu tends to delete the php session data on a cron cycle, and I’m fairly sure this is possible on CentOS too. I don’t see the same problems, but I imagine the issue is related (a bit) to changing IP address.

  • I agree it is not possible to keep logged in during updates etc, but I’d like to stay logged in during normal gui operations. I thought the settings had to do with log in session, but it not, what is the meaning of this setting? Could it be removed not to make users confused?

  • Yeah, there’s nothing I can do to fix that. There are multiple instances of when and where things will log out. One being after updates, if the service dies, it can delete the session data that was associated with it (httpd/apache2 restart after an update.)