Unable to register Dell Inspiron 13 7000 Series to fog server



  • Hello,
    i´m using Fog 1.2.0 (Ubuntu 12.04) in an test-environment (VM-Ware Workstation). I´m able to clone Vm´s and physical Machines with the server.
    Now I want to clone a new Dell Inspiron 13 7000 Series, but I get no “fog-boot-Menu” when the client boots over the network. It is also to fast to read an error-message and to fast to stop during booting. I´m sure that the network configuration of Vm-Ware is right, because the client gets an IP from the Server.
    Maybe it is a problem that the client has no physically network-card, only an USB-Network-Adapter. But in the BIOS (UEFI) I choose the Network-Boot Option and I also see the correct Mac-Address of the Adapter.
    When I choose “legacy” instead of “UEFI” in the Bios I can change the Boot-order to Network as first, but nothing happens. I´m sure that “Network” is the first in the boot order.
    Do you have any idea? Thanks!


  • Developer

    @Warrender6 From what I can see in the two screenshots those files are probably on the same system (date and time). So I guess this is still FOG 1.2.0. I am still not sure if you can make this work with 1.2.0 but what is very clear is that init.xz is too small. Somehow got damaged?? You can download a copy straight from here: http://sourceforge.net/p/freeghost/code/HEAD/tree/tags/1.2.0/packages/web/service/ipxe/init.xz?format=raw

    If you want to go FOG trunk we need more information on what went wrong. Exact error messages!



  • In /var/www/fog/service/ipxe I see these files:
    0_1448608004891_fog_kernel.JPG

    At first I upgraded to SVN version, but I´am not completely sure, if this Version is installed and works. Where can I see if I´m using SVN version?
    Then I upgraded to FOG-Trunk. I did a snapshot from the VM. So I can test, up- and downgrade easily. Unfortunately I got a lot of problems: Apache 2 and tftp didn’t start with a lot of errors. So I don´t want to upgrade to the trunk version at work.


  • Developer

    Hmmm, I keep forgetting how old 1.2.0 is. Kernel panic might be coming up because 1.2.0 is missing the initrd=init.xz kernel option. Or it is the kernel/init mismatch as Tom suggested. Which kernel version do you use by the way? (file /var/www/fog/service/ipxe/bzImage - if you see bzImage/init.xz being loaded on client bootup - otherwise bzImage32)

    As I already said - you might want to look into setting up a FOG trunk server (don’t upgrade your running system but setup another machine for testing this) which comes with all the newest things included. https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    If you don’t want to be bothered with the very latest stuff (bug fixes every day!) you better checkout SVN version 4103 which is pretty stable (svn co -r 4103 https://svn.code.sf.net/p/freeghost/code/trunk)


  • Senior Developer

    What files are you using? I usually see that panic if somebody is trying to use unmatching files (64 bit kernel with 32 bit init, or vice versa.)



  • I was to fast and wrote that it works, but it still doesn’t work - sorry for that.
    The fog-menu appears now, but I can´t register the dell-client or clone the client, if I do a pre-staging.
    0_1448548617043_IMG_20151126_152129637.jpg


  • Senior Developer

    I’m solving the thread as a solution for the problem was found. You can continue to talk about different things in here, but I’d actually recommend creating another thread. Storing obscure/unrelated information that doesn’t directly pertain to the question at hand works, but is also very difficult to find for other users as it may not have a title that correlates to what they were searching for.

    Again, you’re free to do as you wish, but I am marking this thread as solved.


  • Moderator

    Yes it is possible. There is a wiki that shows how to do this (I will look in a minute). The idea is that the dhcp server looks at the bootp request to find out the kind of client just asked for an IP address. If an EFI client asks for an IP address it sends the boot file name ipxe.efi file if it is a bios client then it sends undionly.kpxe.

    Let me see if I can find it.

    [Edit] Here you go: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence The arch type of efi x86 is 00006 and efi x64 is 00007 [/Edit]



  • Thank you very much! It works!

    Is it possible to use ipxe.efi and undionly.kpxe with one dhcp-Server? I just konw that you can use static dhcp like this f. e.:
    host dell-client {
    file name=ipxe.efi
    hardware ethernet 00:02:c3:d0:e5:83;
    fixed-address 40.175.42.254;
    }

    Wenn the dell client boot the fog-menu I have to enter the ip of the tftp-Server. Can I automate this?


  • Developer

    ipxe.efi is not part of FOG 1.2.0. I am sorry, should have thought of this earlier!!!

    cd /tftpboot
    sudo wget -O ipxe.efi "http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/ipxe.efi?format=raw"
    sudo chown fog ipxe.efi
    

    Then try booting the client again. As I said USB NICs in UEFI mode is definitely an advanced topic and you might run into new issues within iPXE. Probably best if you can take a picture if things go wrong.

    And remember my first post about the console command in the boot menu. I guess you need to comment this in FOG 1.2.0 to make ipxe.efi work. You might want to look into FOG trunk as well. Probably best if you have a spare machine where you could setup FOG trunk to see if this works out of the box for your USB NIC device.


  • Moderator

    I’m wondering 2 things here.

    First, if you use another computer can you use tftp client to download that file. We want to make sure the permissions on that boot file is not blocking access. You can use another linux computer or a windows computer if you install the tftp client (built in to windows 7+).

    Second, it worked with undionly.kpxe and now with the ipxe.efi it doesn’t. Make sure there is not a blank space on either side of the text in the dhcp server configuration. I’m not seeing anything strange in the pcap files you supplied.



  • Here are two files of wireshark showing the tftp and bootp traffic during booting. Now the dchpd.conf is changed to ipxe.efi. As you can see in the tftp-File there is an error: The ipxe.efi file could not be found.
    Do i need to install something? I just did an upgrade from fog 0.32 to 1.2 and it is the first time that i use the fog server with uefi.

    1_1448436922402_fog_bootp2.pcapng.pcap
    0_1448436922402_fog_tftp2.pcapng.pcap

    Edit:
    These files are in /tftpboot
    0_1448437880560_tftpboot.JPG



  • @Sebastian-Roth
    I changed the dhcpd.conf to ipxe.efi instead auf undionly.kpxe again and I got an other error as you can see in the picture.
    0_1448436120396_error_dell2.JPG

    @george1421
    UEFI mode is on and secure boot is turned off. I interrupted during booting by pressing F12 and chose the network-Adapter IPv4


  • Moderator

    Based on my limited experience with UEFI, IF the bios is in UEFI mode and the legacy ROMS are disabled in the bios AND secure boot is turned off. If these conditions are met then you enter the bios with the USB NIC installed and can see the USB NIC in the selectable devices for booting then that USB NIC should be supported for UEFI booting.

    You should be able to press F12 during the bios post test to bring up the boot menu, from there you should be able to select the USB network adapter for booting, it should be in the UEFI section of the boot menu not under BIOS. Again if these conditions are met you must use the ipxe (boot kernel) that ends in efi. Now there may need to be a specific one for that usb driven NIC, you would see this after the file has been downloaded to the target computer as the kernel boots, you may get network communication issues.


  • Developer

    “Start PXE over IPv4” is UEFI enabled, I am pretty sure. undionly.kpxe does not work in UEFI mode! Please make sure you change dhcpd.conf (ipxe.efi), restart the DHCP service (sudo service isc-dhcp-server restart on ubuntu) and bootup your client again. Make sure the client was turned completely off! Pay attention to the messages you see. It should say:

    ...
    Server IP address is 192.168.1.1
    NBP filename is ipxe.efi
    ...
    

    I have to admit that I am not absolutely sure if others have been successful with USB NICs in UEFI mode yet…



  • @Sebastian-Roth
    A0:CE:C8:06:7E:2B ist the MAC of the Client (Dell).
    00:26:18:94:18:a0 is the MAC of physical Ethernet Card of the Vmware-Server (not the VM).

    I took of a video of the bootup. The booting is really very fast, but i could make a screenshot of the message.
    After that the client boots again.

    0_1448387868030_error_dell.JPG

    Maybe it is importent to know that the Fog-Server works fine with the same Network-Configuration, but other Client-Hardware.
    I also tried to image the Dell-Client with a different Fog-Server (0.32) on Hyper-V, but i got the same mistake.


  • Developer

    I forgot to ask about some more information. I see two clients talking to the DHCP server. 00:26:18:94:18:a0 / 192.168.1.20 probably one of the other clients, right?

    I hope a0:ce:c8:06:7e:2b is your USB NIC adapter, right? This sends a DHCP discovery/request and gets IP 192.168.1.26. Then it downloads undionly.kpxe from the TFTP server. After that I see another DHCP request from the same MAC address (this comes from undionly/iPXE I guess) but no DHCP discovery - which should usually happen before DHCP request. The DHCP server hands a new/different IP to the client: 192.168.1.21

    This is all a bit weird and maybe I am lost here. Please check the MAC addresses and tell me which is which. As well, please tell me what you see when the machine is booting up? Do you see ‘iPXE’ at some point? What happens when things go wrong? Hang or reboot? Probably best if you could take a video of the bootup and post a link here in the forums.



  • @Sebastian-Roth
    Thanks!
    The 2 files (bootp and tftp) are attached.
    1_1448376934980_fog_tftp.pcapng
    0_1448376934979_fog_bootp.pcap


  • Developer

    Can you please install wireshark on the host machine. Start it and capture traffic either on the virtual VM NIC or on the external NIC of the host (you should see the DHCP broadcasts and TFTP traffic either way). Use bootp || tftp as display filter. Then boot up the Inspiron. Please save the packet dump and upload the PCAP-file to the forums so we can have a look!



  • @Sebastian-Roth
    Yes. I´m using the FOG-dhcp.
    In the dhcpd.conf the entry is undionly.kpxe. After changing to ipxe.efi and rebooting the dhcp-Server without errors the client still doesn´t start menu


Log in to reply
 

425
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.