Problem with management interface



  • I’m having a an issue with the management interface.

    On server A:
    I set up fog 0.32 on ubuntu 11.04 using Apache2 + mod_php. Looks and works as expected.

    On server B:
    I copied the fog setup from server A. I did this by creating tar.gz files of /opt/ and /var/www, along with a .sql dumps from the mysql server.

    server B is running on archlinux arm using lighttpd + php-fpm. I have the management interface up and running. I can login and see all the data that was previously on server A.

    The problem that i have with the management interface on server B is that it looks like the css files are not being loaded. If you look at the 2 screenshots attached; the first screenshot shows the management interface of server A and the 2nd screenshot the management interface of server B. On server B if i copy the URLs of the css files (from the page source in the browser or from the .php files) and paste them into my web browser, they load up fine.

    Please help me fix this problem.

    [url="/_imported_xf_attachments/0/98_Screenshot at 2012-04-12 19:55:31.png?:"]Screenshot at 2012-04-12 19:55:31.png[/url][url="/_imported_xf_attachments/0/99_Screenshot at 2012-04-12 19:55:00.png?:"]Screenshot at 2012-04-12 19:55:00.png[/url]



  • Hi

    I have managed somehow to fix the problem i was having.

    Here is a copy of my lighttpd.conf file, hope this of use to someone with the same or similar problem.

    lighttpd.conf (see attached file)

    [url="/_imported_xf_attachments/0/142_lighttpd.conf.txt?:"]lighttpd.conf.txt[/url]



  • Hi

    checked config.php file, found Line 42 in 0…32. IP address is correct.

    Tried to reinstall fog but the installfog.sh script thinks i’m running on ubuntu and fails when apt-get doesn’t work.

    I am running Arch Linux.

    I edited the stylesheet tags in index.php and includes/loginform.include.php to point to absolute URLs and not the default relative URLs; and still that same problem occurs.

    Nothing in lighttpd or php-fpm error logs. You would think if either lighttpd or php-fpm couldn’t load the css files there would be a message in either of their log files.

    Please help me fix this problem.



  • did you edit your config.php file to reflect the change in location?
    Line 42 in 0…32
    [B]define( “WEB_HOST”, “192.168.1.XX” ) ;[/B]

    It may still be pointing to another IP and that is why your images fail to load.

    What I would have done different:
    I would have installed fog with the installer and then dump the database and restore the one from the other server.
    That will ensure everything is properly configured, and by dumping the fresh DB and importing the old, you will get exactly what you want. (Unless there are more options defined in the database. then you will have to address those as well.)


Log in to reply
 

356
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.