UNSOLVED Checking in...Error on GIT 4728

  • When attempting to image, we get an error that simply states “Checking In…” with a counting timer that just keeps going up.

    Per Tom’s request, I’ve included the last few entries of log files from httpd’s error_log .

  • @Tom-Elliott Tom I can confirm that I had to do a FULL wipe as well for it to work. I think it may be database related. I upgraded to the latest, took a copy of the DB then did a FULL wipe. Tested it and everything worked. Restored the database backup, and it started the issue again. Not a huge deal since I have my snapshots and went to a known working version again though.

  • @Tom-Elliott Doing a FULL wipe fixed it for me. Wiping my database and everything and starting over fixed it.

  • So I’ve tested, upload, download, download - multicast, and multicast session joining, and I am not seeing any issues. Are you all still running the same version of FOG (e.g. 4728) or are you updating and still hitting snags on occasion?

  • I’m going to be testing this then. Maybe the checkin issue is specific to mc_checkin.php?

  • I’ve narrowed it to multicast sessions. Unicast seems to work ok.

  • I’m having the same issue since GIT version 4758. I’ve updated today to version 4770 and this is the error I’m getting:

    [Mon Sep 28 10:48:29.282884 2015] [:error] [pid 10853] [client X.X.X.X:58870] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes) in /var/www/html/fog/lib/fog/FOGBase.class.php on line 75

    I’ve tried to maximize the php memory even to 2048MB but I keep getting the same error.:(

  • Sorry to keep blowing this up with more information, but I seem to have narrowed it down to this:


    Looks like 500 errors, but I’m tailing the error log and I havent seen 1 error come up. I corrected the strpos() error first as that was hard to manage looking at.

    OK - after running that specific line in a browser from my personal machine, I get the following message. Not sure if it helps at all though:

    [Thu Sep 24 14:34:00.303317 2015] [:error] [pid 25564] [client] PHP Fatal error:  Uncaught exception 'Exception' with message 'Invalid MAC Address!' in /var/www/html/fog/lib/fog/FOGBase.class.php:539\nStack trace:\n#0 /var/www/html/fog/lib/reg-task/TaskingElement.class.php(12): FOGBase->getHostItem(false)\n#1 [internal function]: TaskingElement->__construct('')\n#2 /var/www/html/fog/lib/fog/FOGBase.class.php(108): ReflectionClass->newInstance('')\n#3 /var/www/html/fog/service/Pre_Stage1.php(3): FOGBase->getClass('TaskQueue')\n#4 {main}\n  thrown in /var/www/html/fog/lib/fog/FOGBase.class.php on line 539

  • Here is the access_log with a snippet around the host that is currently sitting on the checking in prompt. IP is


    I think the relevent line is this one: - - [24/Sep/2015:09:08:28 -0400] "GET /fog/service/Pre_Stage1.php?mac=48:5b:39:5d:c0:5f&type=down HTTP/1.1" 500 - "-" "Wget/1.16.3 (linux-gnu)"

    The problem is that the error log file doesnt start ANY errors until I did the upgrade to try and correct this, beginning at 9:13AM.

  • Well, my issue is back after updating to build 4743.

    See attached error log. error_log

    I updated yesterday to build 4743 and it stopped working, so I updated again today to 4752 and it still is not working.

  • @Killklli So every error that is in your attached error log is still occurring?

    What does the version in the cloud on you system say? You say you updated, but the Page::sendHeaders() message you seem to be getting hasn’t been in for at least the last 10 or so revisions. The “using $this” out of context message you’re seeing is not possible unless the server that is currently showing under FOG Configuration->FOG Settings->Web Server->FOG_WEB_HOST is not the same as the server you typically use to access your GUI. It’s this particular server (THE FOG_WEB_HOST) that needs to be updated as this is what’s called to do Checking in.

    If you can provide more details, such as the error logs, when you update and still “see the same problem”. I ask this because I have had cases of people not realizing that the entries in the logs had not been updated.

  • @Killklli
    I would suggest starting fresh then to see if it comes up. You are also updating your storage nodes, correct? I’m not sure if you need to update the storage, but it wouldn’t hurt to try.

  • @Tom-Elliott Even as is with updating multiple times since then. (Both on Git and SVN) I’m still having the issue.

  • Please try updating again.

    I know this issue is fixed, and has been fixed for a little bit now, but those that keep seeing the issues, please update and try again.

  • I have the same issue, after installing the latest git and svn. I also have a worse issue that started on version 4457 where the web interface is all screwed up, different things are all over the place, but it was still working, until the latest git / svn where I get this “Checking in” error

    I’m running FOG using DNSMASQ on ubuntu 14.04.3 LTS Server on VM … thanks.

  • @Tom-Elliott I think you want the error log? error.log Its while two machines are stuck trying to download an image. All of the other files on this thread just seem to be renditions of that file as far as I can tell.

  • @Killklli I need details. As @Marcus-Allen has stated this is now fixed, we need more details from your particular use case. Error logs as described and displayed in this thread would be very useful.

  • @Tom-Elliott Jumping on the wagon a bit right here. I’m still having the issue as well. I just upgraded the GIT version and am still having the checking in timeout and tried the SVN version as well and it has the same issue.

  • @Tom-Elliott

    Upgraded! Thanks again sir for all of your hard work! It really is appreciated.

  • The header sent messages should be fixed (if you update again) though I don’t know how I like the approach. My approach, currently, is to just check if the headers have already been sent, if not send the headers I want. However, as your output of the log already shows, the headers are already sent before then so the headers I would prefer to be sent may not ever actually get sent.

    For now, I’d recommend upgrading just so your server isn’t getting spammed with these errors.