Windows 7 GPT error whin imaging up, but it's not GPT!



  • Hi All,

    Why do I never seem to get the easy problems?

    I use fog to image all the course machines, brilliant all working perfectly. So I thought, why don’t I use it to image my laptop, then if I ever need it, it’s a simple restore for me. Or so I thought.

    The laptop works fine, no errors at all, I ran fix errors from within windows, rebooted it, the check ran fine. The disk is a SSD.

    The machine is using bios, not EFI, I checked by looking for the environment variable listed here http://kb.parallels.com/en/115815

    But I get
    Invalid backup header but valid main header regenerating backup header from main header
    Warning one or more CRCs don’t match, you should repair the disk!

    I attached a photo of the screen.

    Well the message is clear enough, repair the disk, but the disk isn’t GPT, at least according to disk part.

    Any suggestions anyone?

    Thanks

    Julian



  • fixparts /dev/sda worked for me.
    thanks


  • Senior Developer

    It is in GPT, regardless of what windows is telling you. When the initial install was on the system, it was most likely formatted using GPT for the partition layout. Windows is, well, kind of dumb in how it shows you data. It will say “MBR” but in reality, the system IS in MBR, but the GPT segments have not been properly removed.

    Start the upload task as a Debug task. When at the prompt, run: fixparts /dev/sda and Confirm and write the data. Then run the command fog and press enter through all the stops. The upload should happen properly and your disk is now properly setup for MBR.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.