SOLVED FOG Git Installation on Ubuntu 14.04

  • Hi Guys,

    I recently installed FOG from Git and ran into a couple things. Hope this is in the right section.

    1. The Apache portion of the installation on Ubuntu 14.04 fails. The FOG web stuff is installed correctly into /var/www/html/fog, but the /etc/apache2/sites-enabled/001-fog.conf points to /var/www.

    2. Previously on v1.2.0 when viewing “images” via the webgui, there was a column for “size on server” which was pretty handy. Is there a configuration setting that I can enable to bring this back?

    Everything else seems to be working great. Thanks!

  • Can you be more specific on where to enable the “size on server” setting? I’ve looked in the FOG settings and am not seeing it.

    EDIT: Nevermind, found it! FOG_FTP_IMAGE_SIZE. Thanks!

  • Senior Developer

    size on server was a default in 1.2.0, but it was also a performance hog. You can still have this if you would like it, but you must enable it through the FOG COnfiguration -> Fog settings element.

    The apache may fail simply because the webroot is trying to default to /var/www. Try running the installer with:

    ./ --webroot /var/www/html/