Fog Client not communicating



  • Hello Again!

    Fog 1.2 r 4252 on Ubuntu 14.04LTS

    Freshely installed machine and new fog service is returning the following in the logs

    7/29/2015 10:28 PM Service Getting sleep duration…
    7/29/2015 10:28 PM CommunicationHandler URL: http://fog-server/fog/management/index.php?node=client&sub=configure&newService=1
    7/29/2015 10:28 PM CommunicationHandler Error contacting FOG server
    7/29/2015 10:28 PM CommunicationHandler ERROR: The remote name could not be resolved: 'fog-server’
    7/29/2015 10:28 PM Service Using default sleep time
    7/29/2015 10:28 PM Service Sleeping for 60 seconds
    7/29/2015 10:30 PM RegistryHandler 64 bit registry detected
    7/29/2015 10:30 PM Middleware::Communication URL: http://10.10.3.14/fog/management/other/ca.cert.der

    The final line is correct, however nothing is working (ie AD join)

    Thanks in advance.
    Scott



  • Thanks again Tom!


  • Senior Developer

    Open Regedit on the machine. Go to hklm\software\syswow3264 or whatever it is labeled as. This is only if windows is 64 bit. If windows is 32 bit the regkey will be hklm\software

    Look for the FOG keys. Open up and find the label containing fog-server and change it to be that of your fog server. Restart windows and the client should be able to communicate.

    This is only if you’re running the new client.

    If this is the legacy client you need to do one of two things. Simplest in terms of not having to upload a new image if the image has the client; create a DNS record for hostname fog-server that points, at your fog server. The other way is to uninstall fog and reinstall. At the end it will ask what modules you want to enable/disable it also asks for the host to communicate to. Change this value to the ip address of your fog server.


Log in to reply
 

392
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.