(CentOS 7 & Fog Trunk) - Cannot open UDP Socket



  • I followed this walk-through of CentOS 7 & Fog Trunk. (yes, I know beta…)
    http://blog.ibuddy.info/index.php/2015/06/fog-v-1-3-on-centos-7-full-install-guide/

    The deployment takes an image successfully and deploys successfully… but I’m constantly alerted upon initiating any job that “Cannot open UDP Socket: Permission denied”.

    This shows up on every task requested on the fog site… and also shows up on the imaged machine as I’m trying to pull the image just after registering the system.

    7-19-2015 5-29-53 PM.png

    Any ideas on how to correct?



  • @Tom Elliott: Yes, selinux was disabled and removed via:

    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/sysconfig/selinux
    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/selinux/config
    systemctl stop firewalld
    systemctl disable firewalld
    

    Thanks for the reply, the process isn’t being interrupted at this point. I’m not relying on WOL at the moment for my needs.


  • Senior Developer

    I’ve recoded the wake on LAN elements in hopes to make this item operate better. I don’t know how well it will work but it shouldn’t give you a permission denied message any more. One of the biggest changes I’ve made to this is the web request is not from a single server any more. What should happen now is any/all enabled nodes will send the magicpacket that wol needs to wake up.

    This means the wol folder will not be needed and the settings as well. The other notes to this is the way it operates. Not only will a wol packet be sent by all nodes, but it also sends a packet to any/all macs associated to a host. Hopefully this will help. One of the soon to be made changes is also going to be webroot. I will make the webroot variable assigned in the db with the nodes. Why? Because the nodes all have web data that can be used. Not all nodes have to be configured with the same webroot as is currently assumed. For right now it does use the global setting.


  • Senior Developer

    Did you disable selinux?


Log in to reply
 

436
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.