network boot problem (ipxe looking in wrong place)



  • After a failed upgrade to fog-trunk, I couldn’t get fog-1.2.0 to work again either- so I deleted the /var/www/fog and /opt/fog folders (leaving the DB and the /images folder alone) and re-ran the fog-trunk install.

    While I’ve got the web interface back now, booting to fog is broken.

    The issue is that the boot is trying to load a file at http://<ip>/service/ipxe.boot.php that isn’t there.
    The file is, however, at http://<ip>/fog/service/ipxe.boot.php that isn’t there.

    I tried correcting this by adding a softlink in /var/www to point to the /var/www/fog/service directory to no avail, so I’m wondering what the correct way to fix this would be. Is there a setting somewhere I can change to point ipxe to the correct path?



  • Just what I was looking for- thanks!


  • Senior Developer

    Update the /tftpboot/default.ipxe file and change where it says http://IPHERE/fog/service/ipxe/boot.php to http://IPHERE/service/ipxe/boot.php


Log in to reply
 

476
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.