Can't complete tasks and Host Management Error



  • Server CentOS 5.4 Fog 3.2

    I’m new to FOG but it looks promising so I setup a test network outside of my office network. I have just a home style broad band router connected to my office network where the routers IP and gateway is from the office. I have internet access. I can ping between all of the PCs with IP and name, gateway and internet.

    I don’t have VMWare Workstation yet and it appears VMPlayer doesn’t allow IDE v-drives only SCSI so I want to image from a new Windows 7 Pro PC build.

    I can do the quick inventory and the hosts are listed in Host Management on FOG, 2 hosts found and pining returns 2 hosts. But there is a red exclamation icon with the error “unable to resolve hostname : name_of_host”. I can get all the way through the Upload and Advanced Upload Debug but when I get to the Task Management Confirm Task page it is blank, the menu on the left isn’t there and nothing is listed in the scheduled tasks.

    Here is the output of the httpd error log for thaty session
    [Thu Mar 29 13:33:02 2012] [error] [client 172.16.1.253] PHP Notice: Undefined index: noconfirm in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 29, referer: [url]http://172.16.1.1/fog/management/index.php?node=tasks&type=host&direction=up&noconfirm=2[/url]
    [Thu Mar 29 13:33:02 2012] [error] [client 172.16.1.253] PHP Notice: Undefined index: shutdown in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 732, referer: [url]http://172.16.1.1/fog/management/index.php?node=tasks&type=host&direction=up&noconfirm=2[/url]
    [Thu Mar 29 13:33:02 2012] [error] [client 172.16.1.253] PHP Notice: Undefined index: singlesched in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 745, referer: [url]http://172.16.1.1/fog/management/index.php?node=tasks&type=host&direction=up&noconfirm=2[/url]
    [Thu Mar 29 13:33:02 2012] [error] [client 172.16.1.253] PHP Notice: Undefined index: cronsched in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 746, referer: [url]http://172.16.1.1/fog/management/index.php?node=tasks&type=host&direction=up&noconfirm=2[/url]
    [Thu Mar 29 13:33:02 2012] [error] [client 172.16.1.253] PHP Fatal error: Call to undefined function sys_get_temp_dir() in /var/www/html/fog/commons/functions.include.php on line 1552, referer: [url]http://172.16.1.1/fog/management/index.php?node=tasks&type=host&direction=up&noconfirm=2[/url]

    What else is there I can look at? Any FOG logs? I would assume that the red exclamation icon with the error “unable to resolve hostname : name_of_host” is part if not the problem but I’m not understanding why I can inventory the host and have connections to and from all hosts and clients but still have this error.

    Any pointers would be greatly appreciated and in the mean time I will continue to look around for answers.

    Thanks.
    W Bits.



  • Yep that is the conclusion I came to. Except for me it was going up in the PHP versions. I’m running CentOS for the server because that is what I am most familiar with and I tried doing the “upgrades” outlined in one of the FOG Wikis right after I posted this. But no luck and I haven’t been able to get back to it except to load a PC with Ubuntu and download FOG 3.2. Someday.



  • I had one of my systems administrators dig into this a bit and he discovered that it’s the version of PHP that comes with 12.10 that breaks it. He tried downgrading it but was unable to so we just went back to 12.04 for a quick fix.

    Hope this helps.



  • I just installed FOG on Ubuntu 12.10 and am getting the same problem; add host, chose a task, and confirmation page is blank. I can’t complete any tasks because they can’t be confirmed.

    The client goes to FOG splash screen at boot so it’s connecting with the server.



  • I’m looking into this to try and resolve my problems.
    [url]http://fogproject.org/forum/threads/2-problems.397/[/url]


Log in to reply
 

360
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.