SOLVED Not a partclone image anymore


  • Hello all,

    I was having issues with fog all of the sudden, when I went to pxe boot it would open up an ssh session and just sit there. So i updated to the current svn thinking it probably needed updating. I no longer have that issue, now when it goes to image something it reads the image then says fail “this is not a partclone image” but they are partclone images, that I made only a few subversions ago. Any help is appreciated with diagnosing/troubleshooting.


  • That worked, thanks!


  • Alright I will update and let you know what happens. Thanks!


  • @kirkk can you please update once again, and try again?

    I believe I fixed the init_32 issue. Your image most likely is partclone, and the reason things failed was because it didn’t matter which method you used to image, pigz was not working properly on 32 bit. I think this is now fixed, though I need people to confirm.

    Thank you,


  • Yes It looks like that is what is happening to the other test machine.


  • The other, and my best suspicion, is that the “failing” machines are failing because they’re loading the init_32/bzImage32 files and NOT the init/bzImage files. Is this true?


  • I just re-uploded one of my images and immediately attempted to re-deploy it to my 2 test machines, it worked for one but the other still has the partclone image error. so maybe they just need to be re uploaded.


  • Partimage doesn’t read the image, and it looks way different, I definitely remember making the images with partclone then.


  • They are all listed as partclone images, I will change one to partimage and see if it works. Thanks!


  • There is no config file.

    This is changed on the GUI.

    If you go to the image in image management, you can change the format of the image (Partclone/Partimage) right from the definition. If you don’t see the Drop Down to select the image type, you will need to enable it in FOG Configuration->FOG Settings->General Settings->FOG_FORMAT_FLAG_IN_GUI and check the box and save.

    Then you go back to the image in image management and select the appropriate format from the drop down that will now be presented to you.

    Once you save the image, you’ll have to restart the host system so the system knows about the change.


  • Where is that config file located that I can change the value to partimage from partclone.


  • Again, I don’t think this image is of partclone type. My guess is it is of partimage, but it is defined in the definition as Partclone. Please change this and test again.


  • I was on one of the early 3500 revisions, and I was getting the ssh bash error so I updated to revision 3657 and I started getting this error, now I am on revision 3702.


  • @kirkk When, exactly, did you start having the imaging issue? What revision number? From what to what?


  • I am noticing that it is now saying “Starting to restore image (-) to device (/dev/sda1)”
    Where before it was trying to restore from (/tmp/pigz1)


  • @Wayne-Workman None of the images are sysprepped bitlockered or encrypted.


  • It still errors out, but now only says, “this is not partclone image” none of the /usr/share/fog/lib/funcs.sh error.


  • I will do that right now and let you know what I find out.


  • Can you update and try again, does this still happen?

    It looks, to me, like it’s trying to run as partimage, but screwing up somewhere in the midst of that. My guess, the image is of Partimage type, but Partclone is what’s defined for it.


  • @kirkk Are your images sysprepped ? bitlocker’d ? Encrypted ?

393
Online

8.8k
Users

15.5k
Topics

144.5k
Posts