Fog not changing Windows 7 PC to join Domain after Image



  • We have installed FOG server 1.2.0 and used the client from the FOG page link. We have set the FOG configuration pages to join the PC to the domain after it has pushed the image but after image deployment the PC does not join the domain. Looking through the PC FOG logs there is no mention of it attempting to join the domain.

    Any one have this issue and found a resolution ?

    Thank you for your help


  • Moderator

    I’m solving this thread since the OP has not returned and there is good info here for future readers.

    @TRex good job on getting it working, I think you’ll like FOG Trunk and FOG 1.3.0 even more as there are even more good features to make life easy. :-)



  • YES!
    I had not realised I needed to copy the encrypted output string from FOGCrypt.exe to the web-based UI. It joined the domain after a few seconds of sitting at the login screen without intervention.

    Thank you SO MUCH for the responsiveness and help. You guys rock. It looks like I’m going to trash the Acronis Snap Deploy. So far, FOG is better.


  • Moderator

    @TRex said:

    I removed the FOG client from the source and then installed it directly from fogserver. Also ran FOG Prep directly from fogserver, then reloaded the image to server.
    I reimaged the target from the new image and in the log file (see line 62) ‘AD mode requested, confirming settings’, but the next line is ‘Could not find any recognizable digits’. It is attached.fog.log

    For this, I’d say verify your encrypted AD password.

    Re-run FOGCrypt.exe on your desktop and compare the string outputted to what you have set inside the FOG web UI’s ad settings area. Also verify that this is also the correct string for the individual host as well.



  • I removed the FOG client from the source and then installed it directly from fogserver. Also ran FOG Prep directly from fogserver, then reloaded the image to server.
    I reimaged the target from the new image and in the log file (see line 62) ‘AD mode requested, confirming settings’, but the next line is ‘Could not find any recognizable digits’. It is attached.fog.log



  • fog.log
    I waited a moderate amount of time after doing another imaging of the target before copying fog.log – this has the ‘Hello FOG Client’.

    The target is able to ping the FOG server by IP address, but not resolving name.


  • Moderator

    @TRex Line 4 doesn’t mean anything in particular to me. When you install the fog client on the source machine, it normally takes one or two reboots for the c:\fog.log to look good. You will know it’s good because there will be no errors in it. My log on my desk computer for the legacy client includes these lines if it helps:

     8/17/2015 8:57 AM FOG::MODDebug Reading config settings...
     8/17/2015 8:57 AM FOG::MODDebug Reading of config settings passed.
     8/17/2015 8:57 AM FOG::MODDebug Starting Core processing...
     8/17/2015 8:57 AM FOG::MODDebug Operating System ID: 6
     8/17/2015 8:57 AM FOG::MODDebug Operating System Minor: 1
     8/17/2015 8:57 AM FOG::MODDebug MAC ID 0 90:B1:1C:98:03:8C
     8/17/2015 8:57 AM FOG::MODDebug MAC POST String: 90:B1:1C:98:03:8C
     8/17/2015 8:57 AM FOG::MODDebug A user is currently logged in
     8/17/2015 8:57 AM FOG::MODDebug Username: MB\workman.wayne
     8/17/2015 8:57 AM FOG::MODDebug Hostname: R0219508713WDMB
     8/17/2015 8:57 AM FOG::MODDebug Attempting to open connect to: http://x.x.x.x/fog/service/debug.php
     8/17/2015 8:57 AM FOG::MODDebug Server responded with: Hello FOG Client
    

    Perhaps check if you can ping the FOG IP from the source machine using the source machine’s OS. The firewall OR antivirus may have something to do with this. Also try to temporarily disable the firewall and any antivirus to see if it makes a difference.

    You might also set the “FOG Service” to delayed start inside of the OS’s services area. This generally makes the client more reliable. Do this before you upload.

    Also, if at all possible, try to enable the MODDebug - I’m not sure if that’s done during client install or on the server side - but just look for it and enable it if you see it.



  • fog.log Here’s the log. No ‘hello fog client’. I’m guessing line 4 is the key, but don’t know what it means.


  • Moderator

    @TRex That’s too bad about loosing connection, but OK. Did you happen to check the c:\fog.log file before you lost connection? Did you see “hello fog client” anywhere in it?

    If not, that’s fine. When you are able, please provide the c:\fog.log from the source-host and we’ll go from there.



  • I just uninstalled the FOG Service from the source PC and reinstalled it specifying the IP address of the FOG server. I then redid the image and applied it to the target. The target was not joined to the domain, even after rebooting it once. I rebooted again and lost contact with it for some reason. (Using remote connection so can’t do anything more with it right now.)


  • Moderator

    @TRex Generally, you want to use the FOG server’s IP address… Most people will have better results using the IP, as it avoids DNS issues. Although your mileage will vary with using the netBIOS name.

    I recommend you reinstall the FOG Client on your source machine and specify an IP this time, and then re-upload and see what happens.



  • If we are taking about the process of installing the client, above the list of modules where it says ‘What is the IP address or host name of the FOG Web Server? (Blank for default “fogserver”)’, I left it blank because the name of the Ubuntu server is fogserver.


  • Senior Developer

    During the installation process, it asks you for the server information and which modules you want to install (legacy client this is).

    Did you get this when you installed?



  • @Wayne-Workman I did not get a prompt for an IP address (but had already registered the target PC at the FOG menu).


  • Moderator

    @TRex But did you use the IP address of the FOG server when you did the actual installing?



  • @Wayne-Workman I copied and extracted the FogService and FogPrep to a Win file server and installed it from there.


  • Moderator

    @TRex Did you install the client using the fog server’s IP address?



  • I’m having the same problem. I can get around it using NETDOM from the DC, but it would save time if Fog could do this.

    In the target’s C:\fog.log there is no ‘Hello fog client’, but after logging in, I can see the Fog client is running.

    In the host management area of the Fog server, at the AD section, I have the FQDN, a blank for the OU, ‘administrator’ for the Domain User Name, and the correct password toggled to show dots. I don’t know how to use FOGCrypt.

    In the Service Settings section, everything is checked.

    I’m running Ubuntu Server 14.04.3 (with Lubuntu Desktop for now), Fog version 1.2.0. The target is an Optiplex 760.

    I’d appreciate any help.


  • Moderator

    @marktiller You can set it to a delay if you wish, by setting the FOG Service to start as “Delayed”. If it’s not delayed, it’ll try to join as soon as the service starts up and checks. When the service starts largely depends on the hardware and software installed on the host, and how it handles start up.



  • This post is deleted!

Log in to reply
 

373
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.