NFS server unrecognized on Fedora 16



  • When I’am trying to install Fog on fedora 16 i get:

    • Checking package: httpd…OK
    • Checking package: php…OK
    • Checking package: php-gd…OK
    • Checking package: php-cli…OK
    • Checking package: mysql…OK
    • Checking package: mysql-server…OK
    • Checking package: php-mysql…OK
    • Checking package: tftp-server…OK
    • Checking package: nfs-utils…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: make…OK
    • Checking package: m4…OK
    • Checking package: gcc…OK
    • Checking package: gcc-c++…OK
    • Checking package: htmldoc…OK
    • Checking package: perl…OK
    • Checking package: perl-Crypt-PasswdMD5…OK
    • Checking package: lftp…OK
    • Checking package: clamav-update…OK

    Configuring services.

    • Setting up fog user…Exists
    • Setting up and starting MySqlNote: Forwarding request to ‘systemctl enable mysqld.service’.
      …OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web ServerNote: Forwarding request to ‘systemctl enable httpd.service’.
      …OK
    • Restoring user reports…OK
    • Configuring Fresh Clam…OK
    • Setting up storage…OK
      [B] * Setting up and starting NFS Servererror reading information on service nfs: No such file or directory[/B]
      [B]…Failed![/B]

    [B]It looks like fog not recognizing NFS server.[/B]
    [B]I have checked that the NFS server is running and I have:[/B]

    [user@local bin]# [B]systemctl status nfs-server.service[/B]
    nfs-server.service - NFS Server
    [B]Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled)[/B]
    [B] Active: active (running) since Tue, 27 Mar 2012 13:14:45 +0300; 7min ago[/B]
    Main PID: 2816 (rpc.rquotad)
    CGroup: name=systemd:/system/nfs-server.service
    â 2816 /usr/sbin/rpc.rquotad
    â 2831 /usr/sbin/rpc.mountd

    Somebody knows how to solve this issue ?



  • im running FEdora 17 btw



  • Hi Alin,

    I have the same problem but im new to linux and unsure of the specifiks of your solution.

    I have tried to change my function.sh file but i belive this is what was written originally:

    chkconfig nfs on;
    service nfs restart >/dev/null 2>&1;
    service nfs status >/dev/null 2>&1;

    based on what you wrote I have written the following:

    chkconfig nfs-server on;
    systemctl restart nfs-server.service
    systemctl status nfs-server.service
    service nfs restart >/dev/null 2>&1;
    service nfs status >/dev/null 2>&1;

    Have i done it wrong?

    I get this error (remember im totally new to linux) when the above has been changed

    CGroup: name=systemd: /system/nfs-server.service



  • I found the answer.
    You must modify Fog installation kit by modifying in functions.sh file from /lib/redhat on line 108,109 and 110. Change with:
    chkconfig nfs-server.service on
    systemctl restart nfs-server.service
    systemctl status nfs-server.service


Log in to reply
 

460
Online

39010
Users

10725
Topics

101895
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.