Register the Client with the FOG Server Errors



  • 2015-06-09 12.30.38.jpg

    Help, I have installed Fog today and having this attached error when trying to “Register the Client with the FOG Server”

    Thanks in advance.



  • @Tom-Elliott Thanks you, I have just installed the latest Kernel and it now works. Not quite sure what was happening but thank you for your support.


  • Senior Developer

    Undionly.kpxe is correct, but 1.2.0 did NOT install a 3.8.8 core kernel, only 0.32 installed it.

    This tells me the old fog server you had likely has a tftpboot directory structure of:

    /tftpboot/fog/kernel/bzImage
    /tftpboot/pxelinux.0
    /tftpboot/pxelinux.cfg/default

    And so forth.

    Which server is this coming from? I haven’t a clue. Either somebody else still has a running copy of 0.32, or it’s tftpboot contents, and the PXE Boot options on your particular subnet are being directed to look at it.



  • @Tom-Elliott Ok, back to confused… So should it not be undionly.kpxe???

    We had Fog before but never got round to using it. So i wiped the server and the settings in DHCP and setup backup from latest installer from the website today.


  • Senior Developer

    Then that is not a “fresh” install, or somebody did not update your particular scope to look at your new FOG Server.



  • @Tom-Elliott It was complete new install today, and our DHCP was setup to point to the FOG server and undionly.kpxe. But getting the screen shot error when add the client to fog.


  • Senior Developer

    @naysweb What do you mean?



  • @Tom-Elliott ahhh I understand now, Yeah all of that is correct on our Windows DHCP.


  • Senior Developer

    Your DHCP server should be setup, right now, to be looking at pxelinux.0, if this was an upgrade from 0.32.

    On linux, the file to edit would normally be:

    /etc/dhcpcd.conf

    However, I’m going to guess you’re in a Windows environment so you’re likely using a Windows Server to provide DHCP for your systems.

    On Windows DHCP you need to edit the DHCP Scope options 66 and 67. 66 will the be IP address of your fog server, 67 will be the filename you’re trying to load. In your case you want to load undionly.kpxe.



  • @Tom-Elliott Based on the fact, that confuses me slightly I’m going to say no :)

    Sorry.


  • Senior Developer

    Well, based on the kernel your screen is showing, you haven’t updated your: next-server/filename information to point at the undionly.kpxe file have you?



  • Version 1.2.0 download today.


  • Senior Developer

    What version of fog?


Log in to reply
 

369
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.