Issue with Fog Server after running updates on Ubuntu 14.04



  • I had some updates for Ubuntu 14.04 and now I can’t get into my FOG server through the GUI. I am getting a page that says I need to run “Database Schema Installer / Updater”. When I run it I am getting an error. The screen shots are supplied.

    Thank you in advance,
    BenFOG Screen shot.jpg


  • Senior Developer

    One of the things I hate about Ubuntu, lately, is exactly this.

    Ever since moving to Upstart to control services, the services seem to no longer be controlled.

    It will start services before the dependent services (Networking, Local system, etc…) is running.

    This breaks other things as well, such as the linux side FOG Services (FOGMulticastManager,FOGScheduler, etc…)

    What’s happening, from what I can see, is it starts mysql before networking is ready. It works for a small amount of time, but then when networking is ACTUALLY ready, the service fails. Upstart is supposed to handle restarting a crashed service, but it’s almost like it was completely forgotten about.



  • Use this fix, should permanently fix for what you’re describing:

    https://github.com/fogproject/fogproject/issues/1



  • I had this happen and had to restart mysql.

    I think the command is: sudo service mysql restart


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.