SOLVED Fog Upgrade 0.31 to 1.2.0

  • I can’t seem to get past the “Database Schema Installer/Updater” when upgrading Fog. I work for a school district, and to make sure the upgrade will work on our live Fog server, I been testing the upgrade to 1.2.0. Every time I try to upgrade, the web Gui either hangs, or will fail. I current have tested a fresh install of 0.31, imported our database and tried the upgrade. The most recent test was me using clonezilla on the live Fog server, copying it to another box so I have an identical copy and trying the upgrade. Both times I get the same exact results, the Gui either hangs, or will give me the database Failed! messed showing a bunch of tables below that it wanted to alter.

    -I have tried making sure the password is correct in /var/www/fog/lib/fog/Config.class.php, which it is.
    -I have completely wiped the password for mysql, changed Config.class.php and get the same results
    -I have tried both “localhost” and the IP of the server in Config.class.php for DATABASE_HOST.
    -I have tried putting all the settings in /opt/fog/.fogsettings before running the installer, still with the same results.

    When I am saying that the Gui will either “hang” (just sits there, bottom left of browser says waiting for “server IP”) or Fail, I am meaning that as I change settings and run the installer, I get both of those results. I have no problems logging into mysql with “mysql -u root -p” with my password. Currently the password is wiped (I thought as a last resort deleting the password may fix it), so I am able to login with “mysql -u root fog” successfully.

    I know a decent amount about Fog, just enough to get myself in trouble. Has anyone experienced this issue or have any ideas as to what might be going on? I was wondering if maybe there was another config file I am needing to edit? If you need more info, let me know. I appreciate any feedback that can help me get past the Schema Updater.Thanks!

  • @Trevelyan Yes, I just restarted it to test, and it came right back up and I was able to login. So it looks good so far! Thanks for trying to help so much btw, I really appreciate it.

  • When you restart, is it ok?

  • I installed a fresh copy of 12.04 server with the same version of Fog that my current server had (0.31) and imported the database. After importing the database I installed the upgrade to 1.2.0. It was Friday evening and I was doing work on the Fog server through a VPN connection, so when I tried to upgrade the Schema it did it’s usual “hang”. I thought I would just figure it out on Tuesday when I came in for work. When I came in for work, to my surprise the test box had upgraded. My only theory is that it took some time to do, not sure why, but it ended up upgrading over the weekend.

    This can be closed for now, but I am still unsure why the Schema would hang for such a long period of time to update the tables in the SQL database.

    A quick note to anyone installing an older version (like 0.31) on ubuntu server 12.04, you will need to install SQL server BEFORE you run the install. I had to run “sudo rm -rf /var/lib/apt/lists/*” and “sudo apt-get update” before SQL server would install properly.

  • (I saw your reply just after I posted this, so ignore it if you’ve fixed it!)

    Try these and tell me which works:

    The one I think should work
    (assumes you’ve set a DB password)

    Edit /opt/fog/.fogsettings
    The following are blank and need to be filled:

    • snmysqluser=“root”
    • snmysqlhost=“localhost”

    Afterwards, run dpkg-reconfigure mysql-server-5.5 and give the same password to reset the mySQL database password

    Or try this

    sudo service mysql stop
    sudo service mysql start

    Does this now make the interface work whilst youre logged in?

    If all else fails, try this and see what happens on next boot

    echo manual | sudo tee /etc/init/mysql.override

  • Just to Note - Tom Elliott was taking a look earlier. Ran into some issues with the distro being old (10.10). I will plan on upgrading to 12.04 and updating this when the upgrade has finished. Since it was 10.10 and not 10.04, I will clean install 12.04 and import the database.