BSOD windows image what am I missing.



  • So trying to make a new windows Image, new install of fog .32; been fairly frustrated with this as I am sure it is something small that I am missing. Here is a short process that I have been doing just to test…

    • install windows 7 64bit from media
    • on boot up hit ctrl+shift+f3 to go into audit mode
    • sysprep; sysprep.exe /oobe /generalize /shutdown
    • go to fog, create task to capture image as a single resizeable ntfs partition
    • turn on computer and capture image
    • push image to my test box, not exactly same hardware but will run windows 64bit as I have installed it before.
    • Images with out error and reboots
    • Windows logo comes up, then BSOD.

    Now it gives me a error "stop: 0x000000f4 (0x00000000000000003, 0xfffffa80046a4630, 0xfffffa80046a4910, 0xfffff8002fe18b0) some hardware failure but computer runs fine and if I install windows 7 manually it works. Push image to a diffrent computer to make sure and windows bsod again. Push image to computer that I pulled Image from and windows comes up no problem.

    Things I have tried:

    • running fogprep before sysprep - bsod
    • capture Image as a multi-partition ntfs none resizeable - works
    • running logging on windows I get last driver to load was kbdhid.sys

    Things I am going to try:

    • create the partition and remove the 100M partition

    I thought that fogprep was no longer needed, aslo read that fog should be fine with single resizeable ntfs partition even on windows 7 with the 100M system part. Any pointers or general name calling is cool as long as it has something to help before I hit computer with a bat… would not hit myself with bat because that would hurt.


  • Senior Developer

    I think there’s a very easy problem/reason, why Win 7 Images (without Sysprep) don’t like Resizable images. It’s likely due to the mbr of the drive. When an image is created using Multi-part, it creates a copy of the mbr and both of the partitions/all of the partitions.

    When an image is created using resizable, it creates the 100mb and system image, but the mbr is provided by the FOG script init.gz file.

    I believe, and I don’t know how to fix that part of it, the mbr this particular method uses is a copy of a sysprepped (generalized) image so as to allow any size drive. If you copy the mbr of a non-sysprepped image, you are, basically, taking the partitioning table with you (as well as the size of the drive it was created on).

    Just my thoughts.



  • Has anyone managed to resolve this as I have 2 Lenovo Thinkpad T400’s to which I sysprepped perfectly fine, I imaged them to the fog server no problem. They both booted up after sysprep no problem, but if I deployed them from the fog server, it actually came up with the above error message, and tried two different images on these.



  • I think they have it working now so you only have to use, single part ntfs resizable.



  • I think is had to do with the small partition windows 7 creates on the drive, thus it is not a single partition (I recall somewhere seeing it posted that it worked with that). However, I always use the multi-part myself with all my windows 7 images (I have 5 12Gb+ images) and don’t have an issue. I am still doing the cave man I image per hardware type though.



  • So I decided to focus on this part of the problem feeling that it would lead me to something.

    Any suggestions on finding why it works when I do a multi-part non resizeable image and not when I have a single partiton resizeable?

    Hmm my statement is not that clear let me elaborate:

    I take my computer and install windows 7 and sysprep it, the image I will take first is: Multiple partition image - Single disk (not Resizeable)

    When I push that image to my test box it works perfectly.

    Now I will pull a new image from the same computer by “Single partiton - ntfs resizeable”

    Then if i push that image to my test computer I get the bsod with:

    “Process or thread crucial to system operation has unexpectedly exited or been terminated.” “stop:0x000000F4”

    This is a windows 7 64bit image.



  • Hmm this sucks; Loaded a machine with part magic and created a partion that covers the whole disk, then installed windows 7. then tried to pull an image. It is uploading it as a raw so the base image is 160G… ehhh… I am about to resign myself to pushing a 10G image.



  • @selutha I run a multi-partition so I can’t say for sure, but look at this setup guide posted in the how-to’s for reference - [url]http://fogproject.org/forum/threads/windows-7-deployment-fog-sad2-driver-tool.380/[/url]

    It looks like you have most everything down and complete / done properly. Just double check your work on a few last things =)



  • [quote=“ssx4life, post: 2385, member: 268”]Have you tried running the full sysprep with an .xml file yet?[/quote]
    yup, sysprep. If I use a multi-partition it goes and completes. Only breaks on single-partition. Thats why I think i have something small wrong.



  • Have you tried running the full sysprep with an .xml file yet?


Log in to reply
 

407
Online

38955
Users

10706
Topics

101576
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.