Fatal Error: Failed to Mount NFS Volume



  • I am having issues uploading my base image for our new HP 745 Laptops. I get: Checking Mounted File System…

    An error has been Detected!

    Fatal Error: Failed to mount NFS Volume.

    Computer will reboot in 1 minute.

    The combatibility test passed on the NIC and drive, and ideas?



  • Man thank you so much, we have our students save their files on SD cards and man does that screw with the mounting process for drives in FOG. Never even thought of that and my employee said today what if we take the card out, problem solved.



  • I would never have thought to ask that… but now I’ll start asking :+1:

    Glad you finally got it working!



  • FIXED! There was SD cards in the Middle School Laptops, this was mounting the card as a drive in FOG SDA1, lesson learned!!! Please note that USB drives and SD cards will mess the images up if left in machines. Thanks for all of your help. THANK YOU THANK YOU.





  • Version 3511
    I also did sudo chmod 777 /images
    Not sure if that was setting the permissions correctly but is still not working.


  • Developer

    what version of fog is your server running?



  • Perhaps before you go messing around with various kernel versions,

    You should tend to those HP 745s first?



  • @michaeloberg said:

    Now I have a different problem with my older HP 3125 laptops.

    HP 3125 – -- – 2013-06-25 Not compatible with Kernel 3.8.8.core

    https://wiki.fogproject.org/wiki/index.php/WorkingDevices

    Try a different Kernel.



  • @michaeloberg

    Your domain stuff doesn’t look right…

    Try to issue 777 permissions recursively on your images directory.

    Is your FOG HDD full?



  • First I want to thank everyone for their help on this forum. I was able to get my FOG updated and it resolved my issues with my new HP 745 G2 laptops. Now I have a different problem with my older HP 3125 laptops. Prior to the upgrade we have imaged these machines hundreds of times without issue. Now all of a sudden when I push an image task to a host, it will look like it is starting the image, then I get the following error:

    Target partition size (7864 MB) is smaller than source (59009 MB). Use option –C to disable size checking (Dangerous).

    So my next though was to manually wipe all partition on the targeted host. Same error as before after doing this. So my next thought was maybe the image is screwed up, so I loaded a clean version of Windows 7 on the laptop with drivers and uploaded that as a test image (only 10 GB). So now when I try to image it doesn’t even attempt to get to the nice blue screen where it tells you the error, rather it just runs through several lines of text and I notice some errors in different parts of the boot process but here they are:

    Starting sshd: OK
    /usr/share/fog/lib/funcs.sh: line 17: export: ‘Machines, DC=mydomain, DC=com: not a valid identifier
    It gives me this error a few times then farther on get this one:
    *Initializing /dev/sda with NTFS partition….error: /dev/sdb2: No such file or directory
    Udevd[2768]: inotify_add_watch(6, /dev/sdb2,10) failed: No such file or directory
    Error: /dev/sdb2: No such file or directory
    Udevd[2768]: inotify_add_watch(6, /dev/sdb2,10) failed: No such file or directory
    Done
    Done
    *Using Hard Disk /dev.sdb
    *Erasing current MBR/CPT Tables………………………….Done
    Awk: fatal: cannot open file ‘/images/234/d1.original.partitions’ for reading (No such file or directory)
    Restoring Partition Tables (MBR)……………………………Done
    No extended partitions……………………………………………Done

    I have tested other images and they all seem to be working. Any suggestions???



  • Update again to the latest trunk version of fog.

    Should only require going into wherever you made /svn/trunk
    and issuing:
    [CODE]svn up
    cd bin
    ./installfog.sh[/CODE]

    See what happens then.



  • Is there anything else we can try? I really need this image uploaded ASAP as I have 400 HP 745 G2 systems to load. Any further help is appreciated, I am open to any suggestions!
    Michael



  • I talked with Tom, he says the “favicon.ico” errors are non-impacting.

    So you should search the forums for the other errors. The WiKi too, and Google, why not?



  • It’s supposed to just take you to a search for “favicon.ico” in the forums.

    You can search for it yourself if it doesn’t work.



  • When I try to click on your link I get a page does not exist error message



  • I would investigate the “favicon.ico” errors first, because there are a lot of them…

    https://forums.fogproject.org/search/favicon.ico?in=titlesposts

    I’m at the end of the day today… about to head home. I’ll help more later.



  • Any ideas?



  • Dang your good, thank you so much so I have attached my error log!
    error.log



  • @ch3i said:

    @michaeloberg

    sudo chmod 755 /tftpboot/error.log
    

    I was just about to say something similar, ch3i… Only I’d recommend 777. But anyways, yeah. After you set the proper permissions on that file, you should be able to get it via TFTP.


 

400
Online

41.5k
Users

12.0k
Topics

113.5k
Posts