Fog PXE boot issue



  • ill start with this:
    Running Ubuntu 14.04 and Fog_1.2.0 currently on a Hp EliteDesk G1 SFF
    Im using my windows server for DHCP and i have options 66 and 67 set

    Ive been trying to get a Fog server up to test to replace our Old Ghost solution since driver support is now at the point where i have to build a new pre boot os every time we get a new model.

    my current issue is when i try to pxe boot it starts the PXE boot and tries to do its business and fails out. i have tried
    undionly.pxe
    undionly.kpxe
    undionly.kkpxe
    undionly.kpxe.INTEL
    ipxe.pxe
    and finally pxelinux.0.old since i had fog server runnign and working before but i couldnt get my old boss to get on board with it

    all of them failed after initialising devices and quit to the HDD too fast to see anything except pxelinux.0.old which gave me unable to locate configuration file. So i started looking around for the config file to see if i needed to so anything to that and i keep coming across people referencing /tftpboot/pxelinux.conf/ directory with config files in it. my server does not have this directory in it. Do i need this? if so where can i get it / create it? ive included the contents of my tftpboot folder and a snapshot of the error while booting.

    here is the contents of my tftpboot folder

    john@BTSD-Fog:/tftpboot$ ls
    boot.txt ipxe.kpxe memdisk undionly.kkpxe undionly.pxe
    default.ipxe ipxe.krn pxelinux.0.old undionly.kpxe vesamenu.c32
    ipxe.kkpxe ipxe.pxe snponly.efi undionly.kpxe.INTEL

    im a linux rookie so you may assume i know nothing if you respond.

    [url="/_imported_xf_attachments/1/1990_IMG_20150512_090726.jpg?:"]IMG_20150512_090726.jpg[/url]



  • that worked like a charm! thank you very much.


  • Senior Developer

    From the sounds of it you’re hitting the console error message. In 1.2.0 I didn’t know what I know now. Can you try upgrading to trunk and see if this helps you out? If anything else I brought back pxelinux.0 so at least maybe we can figure out what is happening.



  • the other ones didnt work and would fail out to booting to the hard drive before i could see what issue they were having


  • Senior Developer

    Why are you using pxelinux.0 as your filename/option 67?


Log in to reply
 

414
Online

39184
Users

10832
Topics

103133
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.