Recent SVN Issues



  • We recently had issues with our single partition Windows 7 Images not expanding, about 30% weren’t expanding. We were already on SVN release so we upgraded to the recent 3333 release. As soon as we did, no host showed that it was registered with the FOG server. We made sure the hosts were registered on the server, but still no host showed registered on the FOG boot.

    We reinstalled Ubuntu and FOG and went back to 1.2, only to find that the images were changed with the SVN releases and most of our images don’t work with the original 1.2.

    So, we tried 3336 and the hosts now show registered on boot, but when we imaged they hostname changer and AD Joining part didn’t work, so we again went back to 1.2 (luckily I had a VM snapshot this time.)

    I want to get back on the SVN, but only if the Windows 7 systems will again rename and rejoin the AD. I do most imaging right after school lets out and don’t have time to rejoin 200 systems manually.

    If anyone has good news about a SVN release I can move to, I would REALLY appreciate it!

    In a related issue, can we download a specific SVN release when we know it worked?

    Thanks!


  • Moderator

    All this talk about joining to specific OUs is kinda gross… (Just my opinion).

    If you don’t want your computer objects to be joined and placed inside the default “computers” OU, you can just change the default…

    I’ve got a nested OU inside my primary OU, it’s called “DEFAULT”. Everything new / renamed that gets joined shows up in there. This way, even if we forget to move the computer where it should go (like “Lab xxxx”, “Conference Room”, etc). The machine will at least get all the policy that we have applied to every machine in the building, and will also grab the right policy on reboot after domain joining.

    It’s super spiffy and it lets me totally avoid all this Specific OU joining stuff.



  • I am working now, except it now doesn’t seem to finish pinging every host when I do a search. I usually add hosts to a group by searching for part of the name, but it never seems to finish resolving the search if there are any more than a couple with the same name. When I turn off FOG no Group Add.jpgall hosts list.jpg


  • Testers

    The main concern now is the resizing of images that you reported at the beginning. I am testing weather or not re uploading the images will solve the inconsistencies.


  • Senior Developer

    So you’re working now?



  • It was an error code 2, which I found a post by Tim E. that said it was something with the AD settings. I had my OU as C-Images instead of C-Imaged (should have taken a typing class in 1985 when I was in high school) and that might not have happened.

    Logs are our friends…Logs are our friends…Logs are our friends…Logs are our friends…Logs are our friends…Ummmmmmm


  • Testers

    Repeat after me the mantra Logs are our friends, Logs are our friends. ;-)



  • Thanks, after going through the log we found the error code and rechecked the AD settings. The OU container was misspelled! AGH.

    We are joining now and are upgrading to 3352 now to test it and hopefully stay there for a while.


  • Testers

    What is the output of the fog.log when it fails to join. Also double check under the host record in Service Settings that hostname changer, and host registration are both checked when this was added to the host records all service settings defaulted to unchecked.


  • Senior Developer

    I’m always working something. You can keep track of the commits that I’m posting though too.

    Either watch github.com/fogproject/fogproject.git or sourceforge.net/p/freeghost/code/HEAD for the titles.



  • I did try that…FOGCrypt came up with the same export (I still had the original file) as expected and I did delete all the fields and refill them in. I also checked the account as well, so those do not appear to be the issue. I am currently resending an image to a new host with 3123 to see if I am working with the old SVN before taking a new snapshot and trying 3352…4th revision today. I think the developers are working something.


  • Testers

    AD join has been working reliably for me almost all the issues in the forums have related to the encrypted password in the config being corrupt in some manner and re encoding and pasting it back in has fixed it. The other issue is generally that the account has been locked for some reason be sure to manually join one machine with the same account to make sure its not something simple like expired account or locked due to failed password attempts.



  • FYI 3123 worked for me for a long time and I finally figured out how to get back to it.

    Just click download snapshot from here.

    http://sourceforge.net/p/freeghost/code/3123/tree/trunk/

    All releases are here and you can download the one you want…which is what I have been looking for!

    http://sourceforge.net/p/freeghost/activity/?page=0&limit=100#554786305fcbc9492ea58278



  • I just reverted back to 3273 to see if it will work. I found the checkbox but it is uncheck be default in this version…is it checked or unchecked in the newest trunk? That may have been my issue. I am trying to get a version to work at this point that IS svn since most of my images are in the new format and aren’t compatible with 1.2.

    I am reverting to a snapshot on the VM to try and find a workable version again, unfortunately I have not kept all my svn versions that did work. Is there an archive somewhere to get old trunk releases? There should be a “most stable” trunk release site…I am hoping I just haven’t found it.

    Thanks


  • Testers

    I am using the legacy client so I have FOG_NEW_CLIENT unchecked and the password filled in for FOG_AD_DEFAULT_PASSWORD_LEGACY.


  • Testers

    Let me know if you still see the resizing issue I am fighting the same bug here http://fogproject.org/forum/threads/images-not-expanding.12811/page-2 as of SVN 3348 which I updated to at 7:30 am but of course an hour later and we already have 2 more releases.



  • I see that, but what should be set? Do we just put the legacy password in from previously and leave the new one blank?


  • Testers

    The newest SVN has a new field for the new fog client that auto populates it may have defaulted to that one over the legacy client or cleared the legacy client password check the settings for both.



  • Nope. Upgraded today to current SVN. The rename works but the rejoin does not. I installed the new client to see if that would fix it but that neither renames or rejoins the host to the AD.

    Maybe I am missing something. I have the Active Directory settings setup exactly like I did before (I screenshot and copy the password to notepad) and still nothing.



  • Thanks!


Log in to reply
 

324
Online

38727
Users

10554
Topics

99920
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.