Host list not appearing



  • Hi All,

    We’re having a problem with our hosts list. When we go to list all hosts, where we once had almost 750 hosts, we now have one. It’s name, MAC address and IP address are all listed as C and when you try to go into the host details, it brings up only “Invalid host ID”. I’ve had a quick dive into the hosts database, and all the hosts records are there, though not having any DB experience I can’t tell if the entries are correctly formatted. Has anyone experienced this before? Any ideas where to look??



  • Ok, so more troubleshooting, and I’ve narrowed it down. After checking all the tables in the database I’ve found that the “Inventory” table is corrupted. I’ve searched around and found out about about the REPAIR TABLE <TABLENAME> command. The result I get is 2 errors:

    • Error | Incorrect key file for table ‘inventory’; try to repair it
    • error | Corrupt

    I’ve also tried using the myisamchk command, though I still get the same results. Again, DB’s are my strong suite, so any pointers would be appreciated!!

    In the event that the table is unrecoverable, where do I do from here?

    Chris

    [url="/_imported_xf_attachments/0/76_fog db error.png?:"]fog db error.png[/url]


Log in to reply
 

458
Online

39010
Users

10725
Topics

101895
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.