FOG::HostnameChanger Domain Error! ('Unknown Error' Code: 2)

  • Hi,

    I am having trouble with getting fog to add machines to the domain. This was working fine and has recently just stopped and I cannot figure out what has changed.

    I get as far as the image being deployed and in the fog log it says 20/04/2015 09:51 FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 2)

    I am not sure what the error code 2 means.

    I have tried changing he password and rebuilt the dll and used fog crypt. When I do this it brings up a different error message which I searched for and it states it is something to do with the password. So I am sure that error code 2 is not password related? I have also checked the hostname changer service is running and that the OU directory listed is correct.


  • Ah ok I understand now - brilliant this has resolved the issue I wasn’t aware that specifying the default OU would have a knock on effect.

    Thanks again for your help

  • The error codes you see are coming from Microsoft. What I told you above is correct. The OU parameter is incorrect, or it’s trying to move the system to the Default OU. The Error code 2 means it’s having issues placing the system into the OU.

  • I have previously had fog set up to join different OUs depending on the department the machine will be located. Separated by the | symbol and the default OU being set by the ;

    It use to work a treat but I have since removed all this to try and fix the current issue. Still the same message in the log file and it is just not joining the domain. Not sure what it is failing on as it says HostnameChanger Domain Error! (‘Unknown Error’ Code: 2)

  • What OU have you got set? If you just want them to join the domain to the default Computers Group, remove this from the OU field.