SVN 3192 hangs



  • Hi,

    I’ve just attempted to install SVN3192. All goes well until the “Downloading new FOG Client file…” message and it just sits there.

    I’ve waited about half an hour but no joy. It downloads the kernels and inits ok. I’ve checked the installation log but it just shows the same as the installation screen…stops on the client install.

    I’m on Ubuntu 12.04.5 LTS OS, and was previously on SVN 21xx (I think!)

    Any ideas? Should it only take seconds to download the new client file, how long do I wait?

    Thanks in advance, Mark

    [url="/_imported_xf_attachments/1/1844_fogclient.jpg?:"]fogclient.jpg[/url]


  • Moderator

    [quote=“Tom Elliott, post: 45098, member: 7271”]@ch3i,

    Are you still having this issue?[/quote]

    Tom, I update from 3200 to 3222 without problem, It’s fixed for me.

    Thank you ;)

    Regards,
    Ch3i.



  • I just tried upgrading to 3222 and am getting this client error “Failed to get client version”. Here are my logs.

    [CODE] php -v
    PHP 5.5.9-1ubuntu4.7 (cli) (built: Mar 16 2015 20:48:03)
    Copyright © 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright © 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright © 1999-2014, by Zend Technologies
    [/CODE]

    [CODE]php -m
    [PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    curl
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mhash
    mysql
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    soap
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    Zend OPcache
    zip
    zlib

    [Zend Modules]
    Zend OPcache
    [/CODE]


  • Senior Developer

    @ch3i,

    Are you still having this issue?


  • Moderator

    Hi,

    Below informations of php (if it can help)

    php -v

    [CODE]PHP 5.4.39-0+deb7u1 (cli) (built: Mar 20 2015 15:16:28)
    Copyright © 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright © 1998-2014 Zend Technologies
    [/CODE]

    php -m

    [CODE][PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    curl
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mcrypt
    mhash
    mysql
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    Reflection
    session
    shmop
    SimpleXML
    soap
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    zip
    zlib

    [Zend Modules]
    [/CODE]

    Regards,
    Ch3i.



  • [quote=“Tom Elliott, post: 45028, member: 7271”]Maurice,

    What revision is this occurring on? Have you updated to 3218 and see if this still exists?[/quote]

    I was testing rev 3218, but after updating to rev 3220 a few minutes ago, the FOG Client file downloaded OK. So wow!

    I’ve never see FOG development move so quickly.

    Thanks!


  • Moderator

    Tom,

    I looked here: [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/client/[/url]
    But FOGService.msi is not there. Where is it?


  • Moderator

    [quote=“Mark Shelton, post: 45080, member: 423”]OK, just tried with 3221, which must have been submitted in the last hour. Still fails but I get a message now. Screenshot attached.
    Regards, Mark[/quote]

    Mark,

    I just tested a work-around because I ran into this at home…

    go to here:
    [CODE]/root/svn/trunk/lib/<your flavor of linux>/[/CODE]
    edit this file:
    [CODE]functions.sh[/CODE]

    towards the bottom, you’ll see stuff about "New FOG Client"
    It’ll look like this, depending on your flavor of linux… but it’ll be similar…

    [CODE]if [ ! -f “$webredirect” ]
    then
    echo “<?php header(‘Location: ./fog/index.php’);?>” > $webredirect;
    fi
    echo “OK”;
    echo -n " * Downloading New FOG Client file…";
    cwd=pwd;
    cd $webdirdest/service;
    count=0;
    while [ -z “$clientVer” -a “$count” -le 10 ]; do
    clientVer=php -f ${webdirdest}/service/getclient.php;
    count=expr $count '+' 1
    sleep 2;
    done
    if [ -z “$clientVer” ]; then
    echo "Failed to get client version"
    exit 1
    fi
    [/CODE]

    Where you see this line:
    [CODE]exit 1[/CODE]

    Just put a hash tag in front of it like this:
    [CODE]#exit 1[/CODE]

    What this does is allow the script to try to download the new fog client, but if it fails, it won’t exit the installation script…

    If you do this, I’d still highly recommend working with Tom fully to try to resolve the issue though.
    Also, if your install fails to download the new fog client, YOU WON’T HAVE THE NEW FOG CLIENT… so don’t try to use it.

    However, the old client will still be available for use.



  • OK, just tried with 3221, which must have been submitted in the last hour. Still fails but I get a message now. Screenshot attached.
    Regards, Mark

    [url="/_imported_xf_attachments/1/1849_3221error.jpg?:"]3221error.jpg[/url]



  • [B]Tom…[/B]
    foguser@HBImageserver:~$ sudo php -v
    [sudo] password for foguser:
    PHP 5.3.10-1ubuntu3.17 with Suhosin-Patch (cli) (built: Mar 17 2015 12:01:11)
    Copyright © 1997-2012 The PHP Group
    Zend Engine v2.3.0, Copyright © 1998-2012 Zend Technologies
    foguser@HBImageserver:~$
    [B]and…[/B]
    foguser@HBImageserver:~$ sudo php -m
    [PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    curl
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mcrypt
    mhash
    mysql
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    soap
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    zip
    zlib

    [Zend Modules]

    Regards,
    Mark



  • Hi Tom,

    I’ve just lost connection to my FOG server at work. I’m going to have to go in and check that out. I’ll post the results. Thanks, Mark


  • Senior Developer

    Mark,

    What is the output of the command:
    [code]php -v[/code]

    and

    [code]php -m[/code]



  • Hi Wayne, I downloaded and tried the latest SVN literally 25 minutes ago - SVN 3220. Unless Tom has made changes in the last 25 minutes it still does not work for me. Please advise where the “Download new FOG Client file” can be bypassed. Thanks, Mark


  • Moderator

    Tom fixed this for me today. Try the latest revision.



  • SVN 3220 still hangs on “Downloading new FOG CLient file”. I dont receive any messages. Nothing in the syslog file.
    Ubuntu 12.04.5 LTS. If someone could let me know where the script is that attempts to download the new client file I’ll comment that out. Thanks, Mark



  • Multicast worked well! I still have to do a bootrec -fixmbr and bootrec -fixboot from the Win7 recovery console, but I suspect that is due to something funky in my image. All 3 machines boot and run well!


  • Senior Developer

    Those errors are normal during a download job, it’s particular to what I’ve added to the kernel. Epolling support is now included which is why you’re seeing the errors. They’re nothing really impacting just more informative.



  • Multicast deploy is still running, but I’m getting some interesting errors. I’ve attached screenshots, but it is showing “Error opening USB device ‘descriptors’ file” now as partclone is running. [ATTACH]1847[/ATTACH][ATTACH]1848[/ATTACH] I also got a snap of the error before partclone starts: "error: /dev/sda3: No such file or directory … udevd[2755]: inotify_add_watch(6, /dev/sda3, 10) failed: No Such file or directory … and so on. [ATTACH]1846[/ATTACH] I’m going to let it run to see what happens.

    [url="/_imported_xf_attachments/1/1846_IMG_0012.JPG?:"]IMG_0012.JPG[/url][url="/_imported_xf_attachments/1/1848_IMG_0014.JPG?:"]IMG_0014.JPG[/url][url="/_imported_xf_attachments/1/1847_IMG_0013.JPG?:"]IMG_0013.JPG[/url]



  • svn up brought me to 3220. Everything looked good, except when prompted to go to fog/management and update the schema, I got the management console instead. I’m guessing this is because I updated the schema after the 3218 install, but not sure. Interestingly, the management console still reports that it is 3218

    Multicasting seems to be working correctly now. I’m currently pushing to three machines, though they didn’t wake on lan as they have before when I created an instant deploy task, but they did fire right into the restore when powered on manually.



  • Got it. Thanks Tom!


Log in to reply
 

377
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.