Gdisk not found during debug upload



  • I’m on the svn 3168 after having problems getting 1.2.0 to work with newer hardware.

    I wanted to create a Windows 7 Image and already get the image uploaded, but the MBR/GPT issue had me looking into fixparts and gdisk -l to check and fix the partitions.

    When i create a normal upload task, i think i can see (shortly) that gdisk is running and printing an error about the GPT-Partion and MBR but using an debug upload task i cannot find gdisk anywhere. I checked the install scripts and downloaded both 32 and 64 init images to mount them and check for the binary (only fdisk to be found).

    See the Screenshot attached. I’m not sure what the /dev/sda1 not found error means but so far i was able to get both partitions correctly uploaded (but not booting when deployed).

    Thank you for any advice

    gdiskmissingfog.png



  • Thanks again for assistance, the initimage works flawless now and i’m stoked to start trying to build my own tools into it.

    I ran into another problem with 0x0000007b and fixed the IDE-Drivers used in my virtualbox-installation to the generic ones.

    The inotify_add_watch error cleared itself mostly, no such errors during upload, 1 error during download but the deployed image boots without problems.

    So thanks again, i’ll start using this software on a larger scale and i hope i can be of assistance in the future.


  • Senior Developer

    If you rerun the installer again (and or update svn) you should now have fixparts once again, sorry about all of that.


  • Senior Developer

    Thanks for letting me know. When I get home I’ll make the corrections to fix this as well. It’ll be probably 2 hours or so.



  • it took some time to download from sf, but i tried the amazingly fast updated images and even though gdisk works now (thank you!), fixparts is still missing.

    i attached a second screenshot of gdisk -l /dev/sda if that is of any interest.

    Thanks again for the work.

    fixpartsmissingfog.pnggdiskworkingfog.png


  • Senior Developer

    Issue should be fixed if not please let me know thank you



  • I’m on 3186, sorry for the typo and thank you so much for confirming the problem!


  • Senior Developer

    Are you still on 3168?

    I’m guessing you’re telling it to rerun the same installer in which case you got the latest inits anyway. I’m making corrections that should fix this issue shortly though.


Log in to reply
 

502
Online

38916
Users

10685
Topics

101347
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.