Asus X200M



  • Hello,

    I have an Asus X200M that I cannot get to communicate with my FOG server. I have gone into the BIOS and disabled Secure Boot. I then Enabled CSM and Network Stack Configuration. On my Asus X200L it then gives me the option to enable “Launch PXE OpROM Policy” This option doesn’t appear in the X200M and leaves me the only network boot option as UEFI: IP4 Realtek PCIe FE family controller. When I try to PXE boot from this it states NBF file loaded successfully, then reboots to the Hard Drive. Please help.

    Thank you


  • Developer

    Which version of FOG do you use? I guess you have 1.2.0 installed, right? It’s written in the small cloud on the web interface login site…

    Please edit /var/www/fog/lib/fog/BootMenu.class.php and search for ‘imgfetch’ (without the quotes). I guess you’ll see this:
    [CODE]…
    $this->kernel = “kernel $bzImage root=/dev/ram0 rw ramdisk_size=$ramsize ip=dhcp dns=$dns keymap=$keymap web=${webserver}${webroot} consoleblank=0”;
    $this->initrd = “imgfetch $imagefile\n”;
    …[/CODE]
    Change it to make it look exactly like this:
    [CODE]…
    $this->kernel = “kernel $bzImage initrd=$initrd root=/dev/ram0 rw ramdisk_size=$ramsize keymap=$keymap web=${webserver}${webroot} consoleblank=0”;
    $this->initrd = “imgfetch $imagefile”;
    …[/CODE]
    And then there is another thing that needs to be changed in the same file. Find all the lines of code with ‘print $this->initrd’
    [CODE]…
    print "$this->kernel …
    print “$this->initrd”;
    …[/CODE]
    should be…
    [CODE]…
    print “$this->initrd”;
    print "$this->kernel …
    …[/CODE]



  • I’m not sure I follow. Could you explain in a bit more detail as to what I would need to do? I’ve read that post but I get a bit lost. I’m not sure where they are making changes and if so to what, and it sounds like they released a specific kernel but I can’t locate it.

    Thank you


  • Developer

    Have you tried my earlier suggestion?? For me this error sounds like the initrd issue on mac os x… see here: [url]http://fogproject.org/forum/threads/mac-support.11033/page-2#post-34584[/url]



  • The server is a WMware Virtual Machine. It is running:

    Ubuntu
    Version 10.10 (maverick)
    Kernal Linux 2.6.35-32-generic
    Gnome 2.32.0

    I registered the (Test) client by hand in the web interface. It DOES show that it is registered when I boot the client to the Fog screen. When I schedule the image deployment it goes through the motions and then gives me an error "Kernel Panic - Not Syncing: VFS: Unable to mount root fs on unknown-block(1,0)


  • Developer

    Which Linux did you choose. And please let us know about the version too (e.g. Ubuntu 14.04).

    Have you ever tried registering that (test) client by hand in the web interface? What happens then when you boot that client? Do you see “registered host” in the headline of the boot menu?? What if you schedule an upload task for this host then? Does it upload?



  • I was able to boot to Linux live from a USB with no issues at all. This is what I used [url]http://www.linuxliveusb.com/en/features[/url]

    Thanks!


  • Developer

    As far as I can see on that video you are pretty close to get things working!! After bootup you see iPXE which loads, gets an IP address via DHCP and also loads the menu! Then it loads the linux kernel and initrd. Kind of weird that you don’t see any error messages but the menu again.
    Could you please try downloading any kind of linux live CD (e.g. ubuntu) and try booting it, just to see how linux in general is running on your X200M. I found an article about someone installing linux on his X200M. Try following this to see if you can boot (not install!) ubuntu: [url]http://sajan.io/blog/asus-x200m-perfect-linux-ubuntu-xubunu-utility-laptop[/url]



  • I’m working with the manufacturer as well to see if they will release a BIOS patch to enable the legacy PXE option. Is there any info I can’t get from them that may be helpful? Drivers or something?

    Thank you,


  • Senior Developer

    The funky boot screen should still be functional, just not able to boot using the console db interface.



  • Does that look normal?



  • Here is a link to download the video to watch the process

    [url]https://mhsinc.egnyte.com/dl/2RmzIMevaL[/url]

    Please let me know your thoughts

    Thank you


  • Developer

    What do you mean by “boot to a VLAN”?? And what is a distorted registration window?

    Screenshots? Error messages…?



  • I looked at the iPXE page and their screen shots differ from mine. It looks like this computer is trying to boot to a VLAN then it times out. It then shows the MAC address and then boots to a distorted registration window.



  • Ok I figured out how to update the Kernal through the web interface. I have tried several different kernals. Basically the same result. If I select the newest unofficial kernal it just comes back to the “Host is not registered” screen after I select Quick Registration. With the kernal you provided I get the error previously listed. The screen that comes up to register your host is blue with white writing and has a solid blank line over the selected field. Please let me know if there is anything else I can provide that may help you troubleshoot this issue.

    Thank you


  • Developer

    FOGWEBDIR is just a placeholder in this case. If you did not modify it when installing the system it should be like this:

    [CODE]cd /var/www/fog/service/ipxe
    …[/CODE]
    And same again with <CURRDATE>. Just a placeholder. For example use 20150309 instead…



  • When I try to update the kernal using [url]http://fogproject.org/wiki/index.php/FAQ[/url] i get “bash: FOGWEBDIR: No such file or directory” when I run the 1st command. I’m running FOG_1.2.0. I checked the link but the information is not very detailed as far was what needs to be done. I may just not be understanding. Thank you for your patience.


  • Developer

    [quote=“Shock2k15, post: 43482, member: 28829”]Kernal Panic - not syncing: VFS: Unable to Mount root fs on unkown-block(1,0)
    Kernal Offset: 0x0 from 0xffffffff81000000 (relocation range: oxffffffff800000000-0xffffffff9ffffffff)
    —{ end Kernal panic - not syncing: VFS: Unable to mount root fs on unkown block(1,0)[/quote]

    For me this error also sounds like the initrd issue on mac os x… see here: [url]http://fogproject.org/forum/threads/mac-support.11033/page-2#post-34584[/url]



  • Not that I am aware of. I know the previous person installed a undionly.kpxe.INTEL file. Is there a way for me to find out if they are 32 bit or 64 bit?

    Thanks,


  • Senior Developer

    This message is normally seen when you have a cross platform file being loaded.

    This means, you have a: 32 bit kernel trying to load on a 64 bit init, or a 64 bit kernel trying to load on a 32 bit init.

    Did you make customizations to the kernel files? For example, did you download a new kernel under the plain (x86) but name it as bzImage?


 

428
Online

41.8k
Users

12.3k
Topics

116.0k
Posts