Windows Wont PXE Boot



  • Hi All,

    I have setup the latest version of FOG on Ubuntu 12.04 as per the instructions on your setup guide.

    I am running it in Virtualbox (latest version as of this post). Setup is fine and I can access the FOG server.
    Details as follows

    Win2k8 Server (Not a VM) - Running DNS and DHCP option 66 & 67 setup as per guide - 172.28.8.1
    FOG server (virtual Box) -
    Static IP - 172.28.8.2
    DNS - 172.28.8.1
    DHCP on server disabled, pointed at 172.28.8.1 in setup

    I have now setup a WIN 7 machine in virtual box, syspreped it and installed the fog client services.
    I changed the System to Network boot as I want to image this machine to the FOG server. The system boots and I get the following error

    FATAL : Could not read from the boot medium! System Halted.

    Both network adaptors on virtual box are set to bridged so that they can see the hardware 2k8 server for DHCP.

    Any one got any ideas? Google search has given me a few results but none of the solutions have worked :(



  • Well found out what was killing VMPlayer from Network booting it was Symantec Network threat protection causing the issue when disabled it works just the way it should. Now I just need to find where to add an exception for vmplayer so I don’t need to keep disabling the network protection.



  • Well I solved the problem it was either the laptop or VM Player 6 moved program to a desktop with VM player 7 and no issues now I will try VMP 7 on the laptop to see if that’s the issue or if it was VMP6 causing the issues I am curious to see what it is and how I will fix it but for now it’s working this way.


  • Developer

    From the packet dump I can see that the TFTP/FOG server receives the clients request for the file undionly.kpxe and answers back with option acknowledgement (see here for details about this: [url]https://tools.ietf.org/html/rfc2347[/url]). Normally the client is supposed to send another request then! My guess is that the server answer does not make it to the client. Can you connect a hub just in front of the client and capture packets there??

    And please check out this troubleshoting guide too: [URL=‘http://www.fogproject.org/wiki/index.php/Tftp_timeout…’]http://www.fogproject.org/wiki/index.php/Tftp_timeout[/URL]


  • Developer

    don’t know why your password was changed, but it’s simple enough to change it again
    [CODE]passwd fog[/CODE]



  • So I tried the default username I created when I set up Ubuntu and that one lets me ftp in but fog username and password come up as incorrect. Anyways here is the dumped file, computer trying to get image is 10.2.8.60

    [url="/_imported_xf_attachments/1/1711_TFTP debug.zip?:"]TFTP debug.zip[/url]



  • So I just tried to run ftp on the fog server itself and it say password is wrong as well, the only password that was changed was the default password for the fog web login which was never connected to the ftp before but it doesn’t work either I am not sure what is going on but I can’t believe that the ftp password is only 6 chars long.



  • made the file but I am unable to FTP into the server the password it says to use at FOG_TFTP_FTP_PASSWORD in ver 1.2 its only 6 characters long and it doesn’t work I am using filezilla which has always worked in the past am I using the wrong password? I mean I remember the other one being about 20 chars long. Forgot to mention shows making a connection just says password is incorrect.


  • Developer

    Looks promising. Seams like the client sends a request to get undionly.kpxe from the TFTP server and the server also responds (second packet). To see this clearly you should get a full packet dump. Maybe try this:
    [CODE]tcpdump -i eth0 -w /tmp/tftp-debug.pcap[/CODE]
    You won’t see any packets on the console then. Run the command, start your client and stop tcpdump with Ctrl-C after your client got the timeout. ZIP and upload that pcap file and I’ll have a look and see what I can see…



  • Ok using tcpdump I get a lot of traffic but caught the ip I was looking for:
    IP 10.2.8.60.2075 > 10.2.8.5.69: 35 RRQ “unidonly.kpxe” octet blksize 1456
    IP 10.2.8.5.52343 > 10.2.8.60.2075: UDP, length 15

    That is the only communication I see which is possible I missed more as there was a lot of code to watch. When I tried to do this command:
    tcpdump -i eth0 -w tftp-debug.pcap
    I get Permission denied


  • Developer

    Not wireshark but you can use tcpdump for that. For simple debugging use this:
    [CODE]tcpdump -i eth0 -nn udp[/CODE]
    ‘udp’ is just a very simple filter so that you don’t see to much other traffic…
    If you want to dig into the packet dump you’re better of writing the captured packets to a pcap file and load that on a different computer where you can use wireshark:
    [CODE]tcpdump -i eth0 -w tftp-debug.pcap[/CODE]
    Change ‘eth0’ to whatever interface on the FOG you use…



  • Can wireshark be ran in terminal mode I installed server mode of Ubuntu and the bare minimum software, so I have no gui interface.


  • Developer

    Can you see TFTP request packets on the server using wireshark??



  • Also tested Clonezilla live CD and chose iPxe boot and this is the result sure seems like NIC isn’t liked I am gonna try another computer in case it doesn’t like the computer it is on for some reason.

    [url="/_imported_xf_attachments/1/1704_fog1.png?:"]fog1.png[/url]



  • Ok tested the TFTP get command on fog server works, Computer with VM installed on it works, VM machine fails with firewall turned off on VM machine definitely seems to dislike the NIC in the VM machine for some reason.



  • VM was at full screen Fog server is on its own machine just the client in the VM


  • Developer

    [quote=“Darrell Lanson, post: 42610, member: 1392”]I am now having a issue with Intel E1000 NIC not working with FOG I am using VM Ware Player 6.0.5 build-2443746 with FOG 1.2.0 and Ubuntu 10.04.4 I am getting a PXE-E32: TFTP open timeout as anyone encountered this issue all the machines I have tried boot no problem just the VM is an issue.[/quote]
    What do I see on that picture?? The client (not a VM or is it fullscreen)?!? Or is the FOG server installed in a VM and this picture just shows one of your clients not being able to boot PXE from this server?Sorry but I don’t understand your description of the issue. Please clarify.

    Maybe this is of help for you: [url]http://fogproject.org/wiki/index.php/Tftp_timeout[/url]



  • I am now having a issue with Intel E1000 NIC not working with FOG I am using VM Ware Player 6.0.5 build-2443746 with FOG 1.2.0 and Ubuntu 10.04.4 I am getting a PXE-E32: TFTP open timeout as anyone encountered this issue all the machines I have tried boot no problem just the VM is an issue.

    [url="/_imported_xf_attachments/1/1703_IMG_20150212_103810.jpg?:"]IMG_20150212_103810.jpg[/url]


  • Developer

    Do you get anything after “Starting network…”???

    The above ‘IP-Config’ warnings/errors derive from the linux kernel (see here: [url]http://lxr.free-electrons.com/source/net/ipv4/ipconfig.c#L1469[/url]). To me that sounds like the kernel has trouble to talk to the network and therefore other things like linux dhclient won’t be able to get an address from the DHCP-server either. This is just guessing as I don’t have an insight into what is really going on in your setup.

    Can you capture the traffic on that virtual network interface within your windows host using wireshark??

    You can try booting any kind of linux live CD (e.g. ubuntu) in that virtualbox container to see if network is alright with that…



  • Actually VM player is free unless its changed lately.


Log in to reply
 

411
Online

39184
Users

10832
Topics

103133
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.