PXE issues with HP DX5150 "Press a key to reboot"



  • Hey everybody,

    I have been racking my brain on this one. So to start off let me give you some background information. I am currently working on getting a FOG server going for our production plant’s machines. Those machines in production are HP DX5150 with AMD Athlon 64 processors. Currently I have two separate FOG servers running Ubuntu Server, one based off 14.04 and the other is 12.04 but both with FOG 1.2.0. Both servers are on our UCS system and are accessible through vSphere Client

    Now here’s the kicker, I have DHCP setup correctly with 066 point to FOG and 067 to undionly.kpxe. I am doing some tests with three separate machines, one is a HP Elitebook Folio 9470 with an Intel i5, the HP DX5150 as mentioned earlier, and a HP Z220 Workstation with a Xeon. So far with the undionly.kpxe I am able to fully register both the Elitebook and Z220 without issue, however, the HP DX5150, the one that matters the most, will not boot to the FOG menu. So since the other two machines were able to fully access the menu that rules out the DHCP being an issue. I have tried every possible .pxe and all errored out. With undionly.kpxe it goes through an initializes the iPXE (1.0.0+) devices and then immediatly fails with a message that reads “Press a key to reboot”. I have searched and searched for a solution but everything is circling back to the same issue. I have updated the BIOS to the latest (7050) and still having issues. Also tried kernal 3.14.2 and 3.6.9 just for the hell of it and still the same issue. I also checked the boot settings and tried SANBOOT, GRUB, and EXIT all resulting the same.

    What am I missing? Is it not possible for this machine to reach FOG due to hardware restrictions being such an old machine? Should I try reverting to FOG 0.32?

    Thanks again for any help



  • You rock Tom!!! That did the trick! You’re right, not so pretty but as long as it works I’m just fine with it.

    UPDATE:

    Ran into an issue when trying to perform a full host registration.

    New error:
    Loglevel=4: command not found
    Could not boot: Exec format error ([url]http://ipxe.org/2e022001[/url])
    Could not boot: Exec format error ([url]http://ipxe.org/2e022001[/url])
    PXE-M0F: Exiting HP PXE ROM.


  • Senior Developer

    GRRRR

    Thats not a problem with your system OR (directly) FOG?

    This issue is known about and is fixed in SVN.

    For the quick fix,

    Edit the file on your server named:

    /var/www/fog/lib/fog/BootMenu.class.php

    Find the line (or lines) that have the word console in them.

    Comment or remove those lines.

    It won’t look pretty, but things will work.



  • Thank you for your response Tom. I tried every possible pxe file and with .kkpxe I get an error that states,

    “Could not configure console: Input/output error ([url]http://ipxe.org/1d8c2139[/url])
    Could not boot : Input/output error ([url]http://ipxe.org/1d8c2139[/url])
    Could not boot : Input/output error ([url]http://ipxe.org/1d8c2139[/url])
    PXE-M0F: Exiting HP PXE ROM.”


  • Senior Developer

    Maybe change the filename from undionly.kpxe to undionly.kkpxe.

    It’s designed for buggy/old bios and if your other machines work with .kpxe, they should work fine with undionly.kkpxe as well.


Log in to reply
 

375
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.