PXE boot to FOG 1.2.0 from FOG 0.32 menu



  • Hello all, I wonder if anyone knows how to PXE boot to iPXE (FOG 1.2.0) menu from PXELinux (FOG 0.32) menu.
    I have modified the PXELinux menu to do a lot of different stuff, and I don’t have time to move all of them over to the new FOG server yet. Has anyone managed to do this? Thanks!

    [url="/_imported_xf_attachments/1/1650_20140612_110726 (1).jpg?:"]20140612_110726 (1).jpg[/url]



  • I did a fresh installation of FOG 1.2.0 (without updating svn) and chainloading pxe is working now.
    I think there may be some updates in the svn which stop chainloading pxe. o_O



  • Thanks for the info!! I will give it a try and report back!! :D


  • Developer

    Hi eric0626
    I’ve upgraded to r3012, and is working for me now.


  • Developer

    Still problems I am afraid.
    If I delete all hosts from the gui, and then quick register one, ( same MAC address as before) I get

    Call to undefined method MACAddress::isImageIgnored() in /var/www/fog/lib/fog/BootMenu.class.php on line 761

    when going to [url]http://http://192.168.1.20/fog/service/ipxe/boot.php[/url]

    I’ll upgrade to 3012 and see how that goes


  • Developer

    I’ve done a clean install of r3010, and have the same problem.

    I’ve got round it by manually adding a host,
    [url]http://http://192.168.1.20/fog/service/ipxe/boot.php[/url]
    then returns data.
    For me it still works even if I delete the host.

    For info for Tom, the error was
    PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/fog/BootMenu.class.php on line 143


  • Developer

    Hi eric0626
    When you tried [url]http://10.2.6.40/fog/service/ipxe/boot.php[/url] in your web browser and got a blank page, did you check the apache error log?
    I am seeing the same now I’ve upgraded to 3010, I get an error 500 in the error log.

    I’m just trying a reinstall on a clean vm.


  • Developer

    First off: I will rewrite all of this in complete steps when we are done, but for now, lets focus on the fragments.

    ipxe.krn needs to be in /tftpboot not in /tftpboot/fog/kernel.

    I see you already have placed /var/www/fog/service/ipxe, that is good.

    Now we need to get the kernel booting.



  • [quote=“Jaymes Driver, post: 42030, member: 3582”]That of course, is always an option, but I should be able to set up a test server tomorrow to assist you further.[/quote]

    OK sounds good! I can wait! Thank you so much Jaymes!! :D


  • Developer

    [quote=“eric0626, post: 42028, member: 357”]LOL!! I’m so tempting to re-install the whole thing because I recall it happens after I updated to a newer svn version.[/quote]

    That of course, is always an option, but I should be able to set up a test server tomorrow to assist you further.


  • Developer

    This post is deleted!


  • [quote=“Jaymes Driver, post: 42013, member: 3582”]At least now we know it isn’t a permission issue :D[/quote]

    LOL!! I’m so tempting to re-install the whole thing because I recall it happens after I updated to a newer svn version.


  • Developer

    At least now we know it isn’t a permission issue :D

    I will see if I can get some time to set up a test server and work on this for you. I used chain loading back when 0.33b was in the works, and it worked well then, We should be able to get it going again.



  • [quote=“Jaymes Driver, post: 42003, member: 3582”]try [code]sudo chmod -R 0777 /var/www/fog/service[/code]
    this will give global read/write permissions just to verify we can get the page to display, we can adjust settings later for 755 or 644.[/quote]

    Hi Jaymes, it seems like it’s still the same. It still displays a blank page.

    [url="/_imported_xf_attachments/1/1672_777 ipxe folder permission.JPG?:"]777 ipxe folder permission.JPG[/url][url="/_imported_xf_attachments/1/1673_777 service folder permission.JPG?:"]777 service folder permission.JPG[/url]


  • Developer

    try [code]sudo chmod -R 0777 /var/www/fog/service[/code]
    this will give global read/write permissions just to verify we can get the page to display, we can adjust settings later for 755 or 644.



  • [quote=“Jaymes Driver, post: 41983, member: 3582”]What are the permissions on the folder, do you have rights to view the content and execute it?[/quote]

    Hi Jaymes, I just check the permissions, and look like no one has execute permission. I’m not sure if I’m correct.
    I have attached a screenshot.

    [url="/_imported_xf_attachments/1/1671_ipxe folder permissions.JPG?:"]ipxe folder permissions.JPG[/url]


  • Developer

    What are the permissions on the folder, do you have rights to view the content and execute it?



  • [quote=“Junkhacker, post: 41953, member: 21583”]yes, that should return the text for the ipxe boot menu. do you have any problems logging into the server through your browser?[/quote]

    I have no problem logging into the server. I’m running svn 2979.

    [url="/_imported_xf_attachments/1/1667_FOG.JPG?:"]FOG.JPG[/url]


  • Developer

    yes, that should return the text for the ipxe boot menu. do you have any problems logging into the server through your browser?



  • [quote=“Junkhacker, post: 41943, member: 21583”]well, what do you get if you enter this in a web browser? [url]http://10.2.6.40/fog/service/ipxe/boot.php[/url][/quote]

    When i enter the link in a web browser, i get a blank page. Even if I do it from the FOG server (10.2.6.40), I still get a blank page.
    I have attached screenshots. Is there anything wrong?

    [url="/_imported_xf_attachments/1/1665_ipxe boot php.JPG?:"]ipxe boot php.JPG[/url][url="/_imported_xf_attachments/1/1666_bootphp.JPG?:"]bootphp.JPG[/url]


Log in to reply
 

348
Online

39.5k
Users

11.1k
Topics

105.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.