UPLOAD /dev/SDA SIT



  • Hey All,

    Sorry to pester but am having a funny issue. Have done a fair bit of troubleshooting using the search bar, but cant seem to resolve my Problem.

    Ive just built a New Fog server, as we are now pushing out 8.1 systems, finally got away from XP! I have two AlienWare PC’s, the Aurora R4 (older) and the Area 51 (newer). The R4 works totally fine with upload and download of the image. The Area 51 however gets stuck when trying to upload the image, and just sits on using hard disk /dev/sda…

    Gone through the SVN process - no change. Also updated the Kernel - no change. Have also moved onto different network equipment isolated from everything else, no change.

    Any help would be greatly appreciated… Im sorry I am being a little vague, but im unsure where else to go.

    Thanks



  • This worked for me! Thank you.

    Had MBR/GPT Partition



  • [quote=“Tom Elliott, post: 41213, member: 7271”]You need to start the upload task as a debug. As you’re on SVN and the most current, this can be done right from the upload deploy task. Just check box that says you want to run it as a debug task.

    Then startup your client.

    It will present you with a terminal screen allowing you to enter commands. At that screen you first type:

    fixparts /dev/sda
    y
    w

    Then you run FOG, and it should work without issue.[/quote]

    Just Ran into the issue my self info:

    New fog build 1.2 ( ubuntu 14.4 VM on hyper V)
    2tb iscsi attached storage
    im able to upload and deploy other computers fine.

    i get stuck on a sony laptop (1TB 5400)
    When uploading an image form the Sony viao its get stuck on "using hard disk /dev/sda"
    Hitting enter the task stops and in the fog GUI it thinks its completed

    Ill try the above method and see how i go



  • I doubt the latter. I Reinstalled the Old Fog server - 0.32 on Ubuntu 10. No issues deploying a Win 7 Image.


  • Senior Developer

    That’s what I’m thinking or you network is completely unreliable.



  • Just an Update.

    I rebuilt the OS and Server from scratch. I have not upgraded to svn. Im still having the same Issue. Ive used clone zilla to at least get a snap shot so i can deploy. Do you think the Servers HDD is having issues?


  • Senior Developer

    is it different everytime?



  • same result on the new network… this time failing at 2%



  • [quote=“Tom Elliott, post: 41246, member: 7271”]Is it possible the disk the image resides on (the server) is corrupt or failing?[/quote]
    its possible… we are at 56% of the upload… should be able to deploy in 15 mins



  • Isolated on a single Router -Just server and PC.

    will see what happens…


  • Developer

    it’s not permissions, or it wouldn’t start. this seems more like the files are getting corrupted in transfer. have you checked the network cables?


  • Senior Developer

    Is it possible the disk the image resides on (the server) is corrupt or failing?



  • Any idea what ould cause this failure half way through the image download? Is it permissions?

    [url="/_imported_xf_attachments/1/1622_image1[1].JPG?:"]image1[1].JPG[/url][url="/_imported_xf_attachments/1/1623_image2.JPG?:"]image2.JPG[/url]



  • interestingly i’m having the same gzip issue with a different PC. a Intel NUC. This time it hits about 8%…



  • aha. by unplugging the 2nd drive, the system does not boot.

    I looked into the Windows Disk Manager, and the System reserved partisan resides on this second Hard Drive - too add to the confusion. I will look into fixing… Somehow!



  • [quote=“Junkhacker, post: 41226, member: 21583”]just for the sake of testing, would you be willing to disconnect the second hard drive and try uploading again?[/quote]

    Of course… We can certainly try…


  • Developer

    just for the sake of testing, would you be willing to disconnect the second hard drive and try uploading again?



  • looks like a gunzip error if that helps…



  • soooo this is interesting. SDA1 was uploaded onto the Image - Appears it uploaded OK.

    On deployment of the image on a sister machine, all appears OK at first.

    Until it gets to 7% and then kicks up a “no directory error”. I’ll do some searching…

    [url="/_imported_xf_attachments/1/1621_IMG_1019.JPG?:"]IMG_1019.JPG[/url]



  • looks like i have the same with the /dev/sbd! freeezes on processing Hard disk. Theres nothing on this disk so ill do the same with fix parts…


Log in to reply
 

345
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.