Cannot register clients



  • I setup my fog server on CentOS 6.6. I’ve had to rebuild a couple times to get around some TFTP timeouts, but this build I’m able to get my client machines to boot and reach the fog boot menu. :) I’m running fog version 2905.

    The problem I’m encountering is when I choose the “perform full host registry and inventory” option, I get this error:
    [CODE]
    /bzImage… ok
    Could not select: Exec format error (http://ipxe.org/2e008001)
    [/CODE]

    The only menu item that I can get to work is the memory test. I get the same error when I try to use any other menu options. I’m not sure where to start looking to find the problem. My initial research led me to ipxe’s page. ([url]http://ipxe.org/err/2e0080[/url]). My gut feeling is that the file links are broken, IE it is looking to load an image through pxe that doesn’t exist.

    I’m pretty new to fog, so I’m not sure how to go about diagnosing this from here. Any suggestions?


  • Senior Developer

    Under storage management->relevant node->path. You change this here. Then you’ll have to update the /etc/exports file to match the new path. Then you need to update the /opt/fog/.fogsettings file so the image location is updated so future upgrades. Make sure to set perms and place the .mntcheck and dev/.mntcheck files and make the new path chmod 777 -R and all should be done.



  • I goofed up my configurations, so I updated to a newer snapshot, but the init.xz files were corrupt again. Anywho, I’ve snapped back to 2911. What I want to do now is specify a different default image storage location. I’m not entirely sure how to do this. I’ve found a couple different how-to’s for previous versions. These how-to’s are no longer relevant I’m afraid. Can I specify the location during install? I’m not looking to add any additional nodes. I’m just looking to use the home folder of a different user so that I can use the extra free disk space.

    Side note: This is an awesome piece of software, and the help so far has been great! How does one become a developer?



  • I should have perhaps hashed those files first, but the good news is that the update worked! I’m having some issues with the image store location though. I can make a separate thread for that if I can’t figure it out. My next goal is to move the location of where fog is storing my images. Thank you so very much for your help thus far!!!


  • Senior Developer

    My best guess that the either one or both the bzImage and init.xz files are corrupt.

    You could re-run the installer to get the files to redownload. I only say this as I’m not having issues running the files. Also, you could try updating to 2911: go into the location where you originally downloaded 2905 and run svn up. Then rerun the installer.


Log in to reply
 

397
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.