Troubleshooting help needed: Upload task delayed scheduling not working correctly.



  • I’ve been beating my head against the wall on this seemingly simple issue. My scheduled image upload tasks don’t start at the scheduled time, they don’t seem to work at all. I’m using Ubuntu Server 12.04.5 LTS i686 operating system and Fog 1.2.0 SVN 2900. What parts of FOG should I be looking at to see why the tasks are not running?



  • I don’t want to get too far off track, but now that i’m squared away with 1.2.0 and things are working, do you recommend I move to the SVN?


  • Senior Developer

    Remember, I’m usually running SVN, and seeing as SVN is much further along, I don’t always remember what was in the past.

    So yes, that’s correct, FOGSnapinReplicator does not exist.



  • I ended up doing a clean install, and installing Fog 1.2.0, no SVN. I changed the time locations as listed above, when I did
    [CODE]sudo service FOGSnapinReplicator restart[/CODE]

    I got

    [CODE]FOGSnapinReplicator: unrecognized service
    [/CODE]

    Did I do something wrong here?



  • Thank you for all of your help Tom, I’m going to revisit this in the morning when I get back into the lab.


  • Senior Developer

    Yeah, as you’re running ubuntu, you need to edit the /etc/php5/apache2/php.ini and /etc/php5/cli/php.ini files.

    Look for, in both of these files, the
    [code];date.timezone[/code]

    Change them to be:
    [code]date.timezone=America/New_York[/code] Of course changing for your relevant timezone.

    Then you will have to restart the apache service and all of the fog services:

    [code]sudo service apache2 restart
    sudo service FOGImageReplicator restart
    sudo service FOGSnapinReplicator restart
    sudo service FOGMulticastManager restart
    sudo service FOGScheduler restart[/code]

    Then the timing should be fixed and hopefully your logs will show the accurate time as well.



  • The vm I have FOG installed on in this location seems to be having some connection issues too now, keep losing my ssh connection and the web interface randomly. I ran the command to check the scheduler log and it was a little suspect. I restarted the FOGScheduler service and this allowed the scheduled task to go active, but it seems my server clock may be off? When I restarted the time in the scheduler log was 1-16-15 1:22 AM, at that time it was actually 1-15-15 7:22 PM. Running "date"at the command line gives the correct date, where else does FOG look for and work with date/time settings?

    [CODE]01-07-15 8:52:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:52:45 pm] * No tasks found!
    [01-07-15 8:53:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:53:45 pm] * No tasks found!
    [01-07-15 8:54:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:54:45 pm] * No tasks found!
    [01-07-15 8:55:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:55:45 pm] * No tasks found!
    [01-07-15 8:56:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:56:45 pm] * No tasks found!
    [01-07-15 8:57:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:57:45 pm] * No tasks found!
    [01-07-15 8:58:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:58:45 pm] * No tasks found!
    [01-07-15 8:59:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 8:59:45 pm] * No tasks found!
    [01-07-15 9:00:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 9:00:45 pm] * No tasks found!
    [01-07-15 9:01:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 9:01:45 pm] * No tasks found!
    [01-07-15 9:02:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 9:02:45 pm] * No tasks found!
    [01-07-15 9:03:45 pm] * 0 active task(s) awaiting check-in.
    [01-07-15 9:03:45 pm] * No tasks found!
    [01-15-15 6:10:01 pm] * Starting FOG Task Scheduler Service
    [01-15-15 6:10:06 pm] * Checking for new tasks every 60 seconds.
    [01-15-15 6:10:06 pm] * Starting service loop.
    [01-15-15 6:10:06 pm] * 0 active task(s) awaiting check-in.
    [01-15-15 6:10:06 pm] * No tasks found!
    [01-16-15 1:18:56 am] * Starting FOG Task Scheduler Service
    [01-16-15 1:19:01 am] * Checking for new tasks every 60 seconds.
    [01-16-15 1:19:01 am] * Starting service loop.
    [01-16-15 1:19:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:19:01 am] * 1 task(s) found.
    [01-16-15 1:19:01 am] * Task run time: Fri, 16 Jan 2015 00:23:00 +0000
    [01-16-15 1:19:01 am] * Found a task that should run…
    [01-16-15 1:19:01 am] - Is a host based task.
    [01-16-15 1:19:01 am] - Task Started for host crlpres!
    [01-16-15 1:19:01 am] - Scheduled Task cleaned.
    [01-16-15 1:20:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:20:01 am] * No tasks found!
    [01-16-15 1:21:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:21:01 am] * No tasks found!
    [01-16-15 1:22:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:22:01 am] * No tasks found!
    [01-16-15 1:23:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:23:01 am] * No tasks found!
    [01-16-15 1:24:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:24:01 am] * No tasks found!
    [01-16-15 1:25:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:25:01 am] * No tasks found!
    [01-16-15 1:26:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:26:01 am] * No tasks found!
    [01-16-15 1:27:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:27:01 am] * No tasks found!
    [01-16-15 1:28:01 am] * 0 active task(s) awaiting check-in.
    [01-16-15 1:28:01 am] * No tasks found!
    [/CODE]


  • Senior Developer

    Easiest way to check from ubuntu would be to check the log.

    As you’re running 2900, you can check with:

    [code]sudo tail -100f /var/log/fog/fogscheduler.log[/code]

    You should see something like:
    [code][01-15-15 6:06:38 pm] * Task run time: Thu, 15 Jan 2015 18:08:38 -0500
    [01-15-15 6:06:38 pm] * Task doesn’t run now.
    [01-15-15 6:07:38 pm] * 0 active task(s) awaiting check-in.
    [01-15-15 6:07:38 pm] * 1 task(s) found.
    [01-15-15 6:07:38 pm] * Task run time: Thu, 15 Jan 2015 18:08:38 -0500
    [01-15-15 6:07:38 pm] * Task doesn’t run now.
    [01-15-15 6:08:38 pm] * 0 active task(s) awaiting check-in.
    [01-15-15 6:08:38 pm] * 1 task(s) found.
    [01-15-15 6:08:38 pm] * Task run time: Thu, 15 Jan 2015 18:08:38 -0500
    [01-15-15 6:08:38 pm] * Found a task that should run…
    [01-15-15 6:08:38 pm] - Is a host based task.
    [01-15-15 6:08:38 pm] - Task Started for host bhs-telliott!
    [01-15-15 6:08:38 pm] - Cron style - No cleaning!
    [01-15-15 6:09:38 pm] * 1 active task(s) awaiting check-in sending WOL request(s).
    [01-15-15 6:09:38 pm] - Host: bhs-telliott WOL sent using MAC: c4:34:6b:28:43:ac
    [01-15-15 6:09:39 pm] * 1 task(s) found.[/code]



  • What is the correct way to check, and what exactly is the service called? FOGScheduler ?
    I type the following

    [CODE] sudo service FOGScheduler status
    [sudo] password for aseikola:
    Usage FOGScheduler {start|stop|restart}
    [/CODE]


  • Senior Developer

    Is the FOG Task Scheduler service actually running?



  • Sorry about that, it shows 2900


  • Senior Developer

    You’re running SVN 2900, or FOG 1.2.0?

    What’s it show in the cloud?


Log in to reply
 

363
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.