Install/update your databse schema - blank page



  • Hi all,

    So trying to install the current svn (2888) into a ubuntu virtual box, something I have done a million times before now however I have never come across this problem so it’s troubling me a bit.
    The install seems to be exactly what I would expect up to the point the installer asks you to navigate to: [url]http://ipaddress/fog/management[/url] to click the install/database scheme button. The page loads fine with the button so I presume this rules out the web server however after clicking the button, usually the page reloads with a message with something like “Database scheme installed, click here to log in” however at the moment all i am getting is a completely white screen at url: ipaddress/fog/management/index.php?node=schemeupdater
    No error messages have shown up on the terminal through the installer and all the packages have installed ok with nothing obvious causing a problem.

    Fog svn 2888
    Ubuntu desktop 12.04 LTS
    Virtual box with enough ram/cpu/hard drive capacity.

    Thanks.



  • Dear Tom,

    I can close this problem. Thanks for the support!

    What I’ve done or learnt -

    I’ve upgraded to svn 2906 just to be sure I have the latest and greatest.
    I rechecked everything I had to patch to get it going on a SuSe platform. Although I didn’t find anything, Doing it again, I might have missed out a mistake I made last time.

    I’ve found that if I enter
    [QUOTE][url]http://localhost/fog/management/index.php[/url][/QUOTE]
    then the redirect keeps the 'index.php
    but if I enter
    [QUOTE][url]http://localhost/fog/management[/url][/QUOTE]
    then the redirect follows
    However, this doesn’t appear to be a problem as the redirect now works and I get the page I expect.

    I found that the new version needs me to enter the PHP SSL extension otherwise I get the error
    [QUOTE]PHP Fatal error: Call to undefined function openssl_pkey_new() in /srv/www/htdocs/fog/lib/fog/FOGCore.class.php on line 522[/QUOTE]
    in the apache error_log.

    Installing this extension required me to restart the apache server.

    Upon retrying, it all burst into life :)

    Thanks again.

    Onto the next challenge.
    Alasdair


  • Senior Developer

    it should be moving to fog/management/index.php?node=schemaupdater

    Why it’s removing the index.php part is a puzzle.



  • Hello Tom,

    The mysql access log suggests to me that attempts are being made to access the db server but something seems strange. The first query
    [QUOTE]SELECT vValue FROM schemaVersion LIMIT 1[/QUOTE]
    (after the SET statement)
    seems to assume that a db already exists with tables.

    Could it be that something in my installation is broken (probably by me) whereby the build up of the db ‘jumps in’ part way through instead of at the beginning with a ‘create database …’? Strange I know but I can’t explain the first entries in the log in another way. Should I be looking in schema.php for this?

    I flushed the logs and then started the installation. I then posted the entire logs above.

    The firewall should be completely down but I will check this again.

    Error 302 is a puzzle. I am not using redirects. The Apache installation / configuration is about as simple as it can be. This is only on a test PC, not on an active server.
    I will also flush the cache of the browser to be sure it isn’t carrying anything over.
    What I do see in the browser (where one types an url in) is that
    [QUOTE][url]http://localhost/fog/management[/url][/QUOTE]
    does move itself on to
    [QUOTE]/fog/management/?node=schemaupdater[/QUOTE]

    I’ll keep searching :)

    Alasdair


  • Senior Developer

    Also, on your access log I see error code 302 (Page moved) are you using apache redirects?


  • Senior Developer

    I don’t mind you piggy backing Alasdair, but what confounds me most on your particular setup is the white page all around. it’s almost like it can’t communicate with the mysql server to begin with. And firewall of some sort is blocking anything being displayed on the browser.



  • BTW - yes SuSe does have selinux.

    Alasdair



  • Dear Tom,

    [COLOR=#000000]I hope you don’t mind me free riding on the back of this thread. You were helping me with the thread[/COLOR]
    [COLOR=#000000]"[URL=‘http://fogproject.org/forum/threads/updated-from-32-to-1-1-0-to-1-1-2-to-1-2-0-user-login-hist-page-blank.11301/unread’][COLOR=#000000]Updated from .32 to 1.1.0 to 1.1.2 to 1.2.0 - User Login Hist page blank" and one proposal was to upgrade to the SVN trunk. I took this option (I can always go back if needed)[/COLOR][/URL][/COLOR]

    [COLOR=#000000][URL=‘http://fogproject.org/forum/threads/updated-from-32-to-1-1-0-to-1-1-2-to-1-2-0-user-login-hist-page-blank.11301/unread’][COLOR=#000000]The problem I am currently facing is very much like Chris’s.[/COLOR][/URL][/COLOR]

    For other readers, the system is openSuSe.

    Following your advice in the other thread, I have upgraded to SVN 2890. The install is fresh (not on top of an old version). I have also removed the database.
    I step through the install and when I get to:

    [I]This can be done by opening a web browser and going to:[/I]
    [I] [url]http://10.1.2.253/fog/management[/url][/I]
    [I] Press [Enter] key when database is updated/installed.[/I]

    I duly go there and sit and wait and look at a blank page, which remains blank.
    To be clear, I understood that Chris saw something before the blank page. I do not see anything. Immediately blank.
    Up to then, the install appears to go without problems.

    Here are the log files:

    [B]Apache error_log[/B]
    AH00557: httpd2-prefork: apr_sockaddr_info_get() failed for juul
    AH00558: httpd2-prefork: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress this message
    [Tue Jan 13 21:40:15.792878 2015] [ssl:warn] [pid 21334] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Tue Jan 13 21:40:15.804895 2015] [mpm_prefork:notice] [pid 21334] AH00163: Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 configured – resuming normal operations
    [Tue Jan 13 21:40:15.804957 2015] [core:notice] [pid 21334] AH00094: Command line: ‘/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND’
    [Tue Jan 13 21:42:09.841342 2015] [mpm_prefork:notice] [pid 21334] AH00170: caught SIGWINCH, shutting down gracefully
    AH00557: httpd2-prefork: apr_sockaddr_info_get() failed for juul
    AH00558: httpd2-prefork: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress this message
    [Tue Jan 13 21:43:35.133904 2015] [ssl:warn] [pid 22078] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Tue Jan 13 21:43:35.146543 2015] [mpm_prefork:notice] [pid 22078] AH00163: Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 configured – resuming normal operations
    [Tue Jan 13 21:43:35.146630 2015] [core:notice] [pid 22078] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND’
    mkdir: cannot create directory ‘/opt/fog/snapins/ssl/’: No such file or directory
    [Tue Jan 13 21:44:34.427524 2015] [php5:error] [pid 22099] [client 10.1.2.253:46616] PHP Fatal error: Call to undefined function openssl_pkey_get_private() in /srv/www/htdocs/fog/lib/fog/FOGCore.class.php on line 537

    [B]Apache access_log[/B]
    ::1 - - [13/Jan/2015:21:42:09 +0100] “OPTIONS * HTTP/1.0” 200 - “-” “Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 (internal dummy connection)”
    ::1 - - [13/Jan/2015:21:42:09 +0100] “OPTIONS * HTTP/1.0” 200 - “-” “Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 (internal dummy connection)”
    ::1 - - [13/Jan/2015:21:42:09 +0100] “OPTIONS * HTTP/1.0” 200 - “-” “Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 (internal dummy connection)”
    ::1 - - [13/Jan/2015:21:42:09 +0100] “OPTIONS * HTTP/1.0” 200 - “-” “Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 (internal dummy connection)”
    ::1 - - [13/Jan/2015:21:42:09 +0100] “OPTIONS * HTTP/1.0” 200 - “-” "Apache/2.4.6 (Linux/SUSE) OpenSSL/1.0.1j PHP/5.4.20 (internal dummy connection)"
    10.1.2.253 - - [13/Jan/2015:21:43:49 +0100] “GET /fog/management/ HTTP/1.1” 302 - “-” "Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0"
    10.1.2.253 - - [13/Jan/2015:21:44:14 +0100] “GET /fog/management/?node=schemaupdater HTTP/1.1” 500 - “-” “Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0”

    [B]mysql access log[/B]
    /usr/sbin/mysqld, Version: 5.5.33-MariaDB-log (openSUSE package). started with:
    Tcp port: 0 Unix socket: /var/run/mysql/mysql.sock
    Time Id Command Argument
    150113 21:44:14 1 Connect root@10.1.2.253 as anonymous on
    1 Query SET NAMES utf8
    1 Query SELECT vValue FROM schemaVersion LIMIT 1
    1 Quit
    150113 21:44:34 2 Connect root@10.1.2.253 as anonymous on
    2 Query SET NAMES utf8
    2 Query SELECT vValue FROM schemaVersion LIMIT 1
    2 Query SELECT * FROM globalSettings WHERE settingKey = ‘FOG_SNAPINDIR’ ORDER BY settingKey ASC
    2 Query SELECT * FROM globalSettings WHERE settingKey = ‘FOG_SNAPINDIR’ ORDER BY settingKey ASC
    2 Quit

    Do you have any ideas what is causing this blank page?

    Thanks!
    Alasdair[URL=‘http://fogproject.org/forum/threads/updated-from-32-to-1-1-0-to-1-1-2-to-1-2-0-user-login-hist-page-blank.11301/unread’][/URL]



  • You’re welcome Mr Tom. Until next time…


  • Senior Developer

    Nice, glad that you helped me find a bug and correct it.



  • No need to apologise at all, fog is an amazing tool far more complicated than I could ever dream of! I am fascinated by it and would always help anyway I can. Slightly star struck that it is always you that comes to the rescue whenever I manage to break it given you appear to be so influential over the development of the svn.

    On other news when i stop fan-girling, have just checked out to svn 2890 - fresh install worked fine including the database scheme install update.


  • Senior Developer

    Yes it can, I just thought you were upgrading on a prior successful install. If it’s fresh and waiting for the DB Schema, the reason /opt/fog doesn’t exist (or /opt/fog/snapins for that matter) is simply because it hasn’t ever been installed yet. Just useful to know what’s going on. Sorry about my failure.



  • I have been fresh installing yes, I have always presumed svn can be installed without fog as a precursor?


  • Senior Developer

    It seems a little odd to me that /opt/fog/snapins doesn’t exist at this point. Are you fresh installing?

    And yes, update to 2890.



  • Still running 2889, want me to move to 2890 then try again?

    dbs@inception-VirtualBox:/var/log/apache2$ sudo chown -R www-data:www-data /opt/fog/snapins
    [sudo] password for dbs:
    chown: cannot access `/opt/fog/snapins’: No such file or directory
    dbs@inception-VirtualBox:/var/log/apache2$


  • Senior Developer

    I updated my post above, the one changing the user should’ve been chown not chmod. chmod modifies permissions, chown changes the owner.



  • Are you wanting the whole /opt/ folder permission changed to www-data? As the chmod command is specific to the directory you run it in no?
    Update:
    dbs@inception-VirtualBox:/var/log/apache2$ sudo chmod -R www-data:www-data /opt/fog/snapins
    [sudo] password for dbs:
    chmod: invalid mode: www-data:www-data' Trychmod --help’ for more information.


  • Senior Developer

    The /opt/fog/snapins/ssl doesn’t make sense to me, but I’m also going to guess (beyond the permissions now being owned by www-data, that it also likely needs rwxr-xr-x rights in the main folder:

    [code]sudo chmod 766 -R /opt/fog/snapins[/code]

    Can you updated to 2890, hopefully I have the context stuff all done properly now?



  • Hey Tom,
    Reinstalled/upgraded to 2889. Still having the same error however i did notice that favicon.ico did install this time.
    Here is the new apache error log:
    [CODE][Tue Jan 13 15:00:28 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.15 with Suhosin-Patch configured – resuming normal operations
    mkdir: cannot create directory /opt/fog/snapins/ssl/': No such file or directory [Tue Jan 13 15:02:03 2015] [error] [client 10.10.3.171] PHP Warning: file_get_contents(/opt/fog/snapins/ssl/.srvprivate.key): failed to open stream: No such file or directory in /var/www/fog/lib/$ [Tue Jan 13 15:02:03 2015] [error] [client 10.10.3.171] PHP Warning: openssl_pkey_get_details() expects parameter 1 to be resource, boolean given in /var/www/fog/lib/fog/FOGCore.class.php on line$ mkdir: cannot create directory/opt/fog/snapins/ssl/’: No such file or directory
    mkdir: cannot create directory /opt/fog/snapins/ssl/': No such file or directory [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] PHP Fatal error: Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$ [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] File does not exist: /var/www/favicon.ico [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] File does not exist: /var/www/favicon.ico mkdir: cannot create directory/opt/fog/snapins/ssl/’: No such file or directory
    [Tue Jan 13 15:19:17 2015] [error] [client 10.10.3.171] PHP Fatal error: Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$
    mkdir: cannot create directory `/opt/fog/snapins/ssl/’: No such file or directory
    [Tue Jan 13 15:19:23 2015] [error] [client 10.10.3.171] PHP Fatal error: Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$

    [/CODE]
    More than happy to help wherever I can! just let me know what you would like me to do :)


  • Senior Developer

    Mac Support is already built in. While it’s not a 100% foolproof solution, it does currently already work.

    I’ll take a look at the error, specifically the one at: PHP Fatal error: Using $this while not in object context.

    For the folder that’s not working properly.

    Can you set the permissions to it to be set to:
    [code]sudo chown -R www-data:www-data /opt/fog/snapins[/code]

    I may have fixed (hopefully) the this context error. If you can upgrade to 2889 it would be handy if you’d be willing to test and help.


Log in to reply
 

474
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.