Install/update your databse schema - blank page



  • Hi all,

    So trying to install the current svn (2888) into a ubuntu virtual box, something I have done a million times before now however I have never come across this problem so it’s troubling me a bit.
    The install seems to be exactly what I would expect up to the point the installer asks you to navigate to: http://ipaddress/fog/management to click the install/database scheme button. The page loads fine with the button so I presume this rules out the web server however after clicking the button, usually the page reloads with a message with something like “Database scheme installed, click here to log in” however at the moment all i am getting is a completely white screen at url: ipaddress/fog/management/index.php?node=schemeupdater
    No error messages have shown up on the terminal through the installer and all the packages have installed ok with nothing obvious causing a problem.

    Fog svn 2888
    Ubuntu desktop 12.04 LTS
    Virtual box with enough ram/cpu/hard drive capacity.

    Thanks.



  • Dear Tom,

    I can close this problem. Thanks for the support!

    What I’ve done or learnt -

    I’ve upgraded to svn 2906 just to be sure I have the latest and greatest.
    I rechecked everything I had to patch to get it going on a SuSe platform. Although I didn’t find anything, Doing it again, I might have missed out a mistake I made last time.

    I’ve found that if I enter
    http://localhost/fog/management/index.phphttp://localhost/fog/management[/QUOTE]
    then the redirect follows
    However, this doesn’t appear to be a problem as the redirect now works and I get the page I expect.

    I found that the new version needs me to enter the PHP SSL extension otherwise I get the error
    [QUOTE]PHP Fatal error: Call to undefined function openssl_pkey_new() in /srv/www/htdocs/fog/lib/fog/FOGCore.class.php on line 522[/QUOTE]
    in the apache error_log.

    Installing this extension required me to restart the apache server.

    Upon retrying, it all burst into life :)

    Thanks again.

    Onto the next challenge.
    Alasdair


  • Senior Developer

    it should be moving to fog/management/index.php?node=schemaupdater

    Why it’s removing the index.php part is a puzzle.



  • Hello Tom,

    The mysql access log suggests to me that attempts are being made to access the db server but something seems strange. The first query
    http://localhost/fog/management[/QUOTE]
    does move itself on to
    [QUOTE]/fog/management/?node=schemaupdater[/QUOTE]

    I’ll keep searching :)

    Alasdair


  • Senior Developer

    Also, on your access log I see error code 302 (Page moved) are you using apache redirects?


  • Senior Developer

    I don’t mind you piggy backing Alasdair, but what confounds me most on your particular setup is the white page all around. it’s almost like it can’t communicate with the mysql server to begin with. And firewall of some sort is blocking anything being displayed on the browser.



  • BTW - yes SuSe does have selinux.

    Alasdair





  • You’re welcome Mr Tom. Until next time…


  • Senior Developer

    Nice, glad that you helped me find a bug and correct it.



  • No need to apologise at all, fog is an amazing tool far more complicated than I could ever dream of! I am fascinated by it and would always help anyway I can. Slightly star struck that it is always you that comes to the rescue whenever I manage to break it given you appear to be so influential over the development of the svn.

    On other news when i stop fan-girling, have just checked out to svn 2890 - fresh install worked fine including the database scheme install update.


  • Senior Developer

    Yes it can, I just thought you were upgrading on a prior successful install. If it’s fresh and waiting for the DB Schema, the reason /opt/fog doesn’t exist (or /opt/fog/snapins for that matter) is simply because it hasn’t ever been installed yet. Just useful to know what’s going on. Sorry about my failure.



  • I have been fresh installing yes, I have always presumed svn can be installed without fog as a precursor?


  • Senior Developer

    It seems a little odd to me that /opt/fog/snapins doesn’t exist at this point. Are you fresh installing?

    And yes, update to 2890.



  • Still running 2889, want me to move to 2890 then try again?

    dbs@inception-VirtualBox:/var/log/apache2$ sudo chown -R www-data:www-data /opt/fog/snapins
    [sudo] password for dbs:
    chown: cannot access `/opt/fog/snapins’: No such file or directory
    dbs@inception-VirtualBox:/var/log/apache2$


  • Senior Developer

    I updated my post above, the one changing the user should’ve been chown not chmod. chmod modifies permissions, chown changes the owner.



  • Are you wanting the whole /opt/ folder permission changed to www-data? As the chmod command is specific to the directory you run it in no?
    Update:
    dbs@inception-VirtualBox:/var/log/apache2$ sudo chmod -R www-data:www-data /opt/fog/snapins
    [sudo] password for dbs:
    chmod: invalid mode: www-data:www-data' Trychmod --help’ for more information.


  • Senior Developer

    The /opt/fog/snapins/ssl doesn’t make sense to me, but I’m also going to guess (beyond the permissions now being owned by www-data, that it also likely needs rwxr-xr-x rights in the main folder:

    sudo chmod 766 -R /opt/fog/snapins
    

    Can you updated to 2890, hopefully I have the context stuff all done properly now?



  • Hey Tom,
    Reinstalled/upgraded to 2889. Still having the same error however i did notice that favicon.ico did install this time.
    Here is the new apache error log:

    [Tue Jan 13 15:00:28 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.15 with Suhosin-Patch configured -- resuming normal operations
    mkdir: cannot create directory `/opt/fog/snapins/ssl/': No such file or directory
    [Tue Jan 13 15:02:03 2015] [error] [client 10.10.3.171] PHP Warning:  file_get_contents(/opt/fog/snapins/ssl/.srvprivate.key): failed to open stream: No such file or directory in /var/www/fog/lib/$
    [Tue Jan 13 15:02:03 2015] [error] [client 10.10.3.171] PHP Warning:  openssl_pkey_get_details() expects parameter 1 to be resource, boolean given in /var/www/fog/lib/fog/FOGCore.class.php on line$
    mkdir: cannot create directory `/opt/fog/snapins/ssl/': No such file or directory
    mkdir: cannot create directory `/opt/fog/snapins/ssl/': No such file or directory
    [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] PHP Fatal error:  Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$
    [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] File does not exist: /var/www/favicon.ico
    [Tue Jan 13 15:02:11 2015] [error] [client 10.10.3.171] File does not exist: /var/www/favicon.ico
    mkdir: cannot create directory `/opt/fog/snapins/ssl/': No such file or directory
    [Tue Jan 13 15:19:17 2015] [error] [client 10.10.3.171] PHP Fatal error:  Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$
    mkdir: cannot create directory `/opt/fog/snapins/ssl/': No such file or directory
    [Tue Jan 13 15:19:23 2015] [error] [client 10.10.3.171] PHP Fatal error:  Using $this when not in object context in /var/www/fog/commons/schema.php on line 912, referer: http://10.10.3.171/fog/man$
    
    
    

    More than happy to help wherever I can! just let me know what you would like me to do :)


  • Senior Developer

    Mac Support is already built in. While it’s not a 100% foolproof solution, it does currently already work.

    I’ll take a look at the error, specifically the one at: PHP Fatal error: Using $this while not in object context.

    For the folder that’s not working properly.

    Can you set the permissions to it to be set to:

    sudo chown -R www-data:www-data /opt/fog/snapins
    

    I may have fixed (hopefully) the this context error. If you can upgrade to 2889 it would be handy if you’d be willing to test and help.


Log in to reply
 

704
Online

38746
Users

10569
Topics

100051
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.