Winload.efi error... Yes, I know.



  • Yes, I know, we’ve been over this before. But is there any new information on it?

    I used the legacy PXE client to image Windows 8.1 UEFI. When the system boots, it complains about winload.efi. I can fix the error by running “bcdboot C:\Windows” from WinPE and deleting the extra boot option. However, I don’t want to do this on every computer I image (I’ve got 25 in waiting).

    I also would really hate to completely redo this image, and I know that I can make bcdboot copy legacy boot files, so it’s not too big of a deal if we can’t get UEFI booting working. But, can we?



  • Tried a multiple partition image - All Disks, no dice. Still the winload.efi error. I’m going to install Windows to a single partition and try again.



  • Sounds good.

    Unfortunately, I have to leave for a bit. But lucky me, imaging be finished two minutes after I leave! :/


  • Senior Developer

    You could maintain the number of paritions, but rather than trying to use the resizable method, try a non-resizable image type. Maybe this will work better, at least it would verify if we’re using the wrong BCD file for the type of image?



  • UEFI systems usually have a Windows 8 mode that you can enable or disable from the UEFI setup (non-big OEM systems have this). It should disable secure boot.

    As for the image, I’m going to see if I get get it working by pre-partitioning the system and making Windows use the one partition only. I will update you on how this goes.


  • Senior Developer

    I guess I’m not understanding what you mean “mode”?

    What are the imaging steps you’re using? Right now resizable images (and in SVN too I suppose) probably wouldn’t work because in 1.2.0 we didn’t know anything about the BCD stores for Windows 8/8.1. We have since learned (at least from a basic operating point – assumed legacy modeling?) that the Same BCD that works for Windows 7 also works for Windows 8 and Windows 8.1, though if it works for UEFI I’m not sure. I have not been able to test any regards of EFI/UEFI and pxe or imaging in any sense.

    The only relevant starting point I can give is you would need to use the (either: snp|snponly|ipxe).efi files as the initial boot file. The fact that it’s complaining about winload.efi is probably specific to the generated BCD file, not necessarily the imaging process directly.



  • Windows 8.1 mode isn’t enabled, so Secure Boot shouldn’t be doing ANYTHING. I have the machine sitting next to me, so any steps you can give me would be great.


  • Senior Developer

    Again, I don’t have any systems to even start testing the capabilities of (i)PXE booting over UEFI native modes.

    I definitely want to get this figured out though.

    If you’re able to legacy PXE boot the system to do the image, you don’t need to disable UEFI, but you would need to disable Secure Boot. Once the imaging process is complete, you’d need to reenable the Secure boot item. Of course that’s only to get rid of the warning Windows 8/8.1 gives telling you it’s not running in SecureBoot mode.


Log in to reply
 

361
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.