GUI hangs when listing images



  • Searches are relatively responsive but “list all images” takes about 5 minutes and hangs the browser tab until it is done. This isn’t critical but it would be desirable for this to work.

    Current: svn 2868 on CentOS 6.6

    First noticed this after I updated from svn 1858 to what I think was svn 2759 (or right around).

    I bring the following up in case there is a helpful clue:

    -No errors found in logs

    -FOG_MEMORY_LIMIT=1024 made no detectable difference

    -Storage nodes work but dashboard disk info fails to connect to them. Not trying to solve this unless it is a symptom of a more significant issue. Credentials stored work to connect to database through SSH. I did have to change the default image directory to /home/fog. This issue predates image list issue

    -I have 43 images taking up just under 1TB.



  • For now I will do some housekeeping. Some of the images can be deleted and some of them can be stored offline.

    Thanks!


  • Senior Developer

    FOG_MEMORY_LIMIT wouldn’t have made a difference as the hold up is the 43 times to connect to FTP to get the file sizes.

    I suppose I should make an “On/Off” feature for this as it could pose serious delays such as you’re describing.

    Dashboard info likely doesn’t display info probably just because of the shear number of changes. My guess, the other nodes aren’t on the same revision. Putting them up to the same revision should correct this, or at least help us fix the problem. Though if you’re not worried about it, it shouldn’t impact anything too severely.


Log in to reply
 

489
Online

38916
Users

10685
Topics

101361
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.