Can't image a laptop after server reboot



  • First some particulars
    CentOS 6.5 (latest)
    FoG 1.2

    The laptop being imaged is a Dell Latitude E5540

    At one point, the server was working fine. I reimaged this very laptop several times while working on my OS image. We’ve since had to move the server and so the system was rebooted. Now, it seems that the PXE client gets through the DHCP setup OK but ends in the iPXE 1.0.0 (3a02) initialization with…

    /default.ipxe… Permission denied (http://ipxe.org/0212603c)

    This WAS working. I’ve adjusted permissions to be most generous to no effect. I’ve tested manually to see that I can DL from the server via TFTP and that seems to work fine. I’ve also opened up the /images folder, also without effect. There are a couple of similar problems on this forum but nothing exactly like mine.

    Also, I tried deleting and reregistering the laptop with FOG. It did work but it took a couple of tries. The failures were the same error. It almost feels like a timeout issue, though the error comes back pretty quick.

    Any ideas?

    Thanks for the help in advance,

    John



  • Hi Tom,

    As it turns out, the problem was a self inflicted wound. Our Apple guy also has ain image server running. He turned it on the other day. I noticed in the logs that the system would ask for an address first from the FOG server and then from the Apple image server immediately after that. It would then invariably die while trying to connect to the Apple server. I unplugged then network card on the apple box and stuff started working again.

    Thanks for the help!

    John


  • Senior Developer

    Running through the tftp steps, are you able to download the default.ipxe file? If you can, what is in it (it should be a simple text file)



  • Hi Tom,

    SElinux is disabled.
    http://x.x.x.x/fog/service/ipxe/bg.png --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 10000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=y.y.y.y keymap= web=x.x.x.x/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=y.y.y.y keymap= web=x.x.x.x/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=y.y.y.y keymap= web=x.x.x.x/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    autoboot
    The IPs on the kernel lines are correct and obfuscated.


  • Senior Developer

    The default.ipxe permission denied sounds more like something’s blocking access to the /tftpboot folder. Have you ensured SELinux is disabled, or the appropriate restrictions for the /tftpboot folder and program through SELinux are setup?


Log in to reply
 

402
Online

38731
Users

10556
Topics

99953
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.