FOG 1.2 Boot problem



  • Hi All,
    i’ve update from 0.32 to 1.2, now i’m having trobules booting DHCP clients. i’ve update DHCP conf parameters setting boot file to [FONT=Consolas]undionly.kpxe.[/FONT]
    [FONT=Consolas]clients boot correctly but hangs on loading boot.php… after that nothing happens on clients or server… no errors in apache2/access.log [/FONT]
    [FONT=Consolas]if i try to navigate to [url]http://<myip>/fog/services/ipxe/boot.php[/url] i get this output:[/FONT]
    [CODE]#!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    colour --rgb 0xff6600 2
    cpair --foreground 7 --background 2 2
    console --picture http://192.168.1.21/fog/service/ipxe/bg.png --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 5000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= keymap= web=192.168.1.21/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= keymap= web=192.168.1.21/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= keymap= web=192.168.1.21/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    autoboot[/CODE]

    Any kind of help is appreciated.
    Thank you very much
    Daniele.

    [COLOR=#000000] [/COLOR]



  • yes it is.


  • Senior Developer

    Is 192.168.1.21 the IP of your FOG Server?



  • disabled ufw service,
    [URL=‘http://192.168.100.100/fog/service/ipxe/boot.php’]http://192.168.1.21/fog/service/ipxe/boot.php[/URL]
    is the last line show in client, after that nothing happens.
    in /apache2/access.log i see this line (192.168.1.92 is client’s IP):
    192.168.1.92 - - [22/Dec/2014:11:45:54 +0100] “POST /fog/service/ipxe/boot.php HTTP/1.1” 200 1616 “-” “iPXE/1.0.0+ (3a02)”


  • Senior Developer

    When iPXE is making the request to boot.php, is it attempting to load from the correct ip?

    It should output something along the lines of:

    [url]http://192.168.100.100/fog/service/ipxe/boot.php[/url]

    Also, can you ensure there’s no firewall blocking access?

    [code]sudo service ufw disable[/code]


Log in to reply
 

377
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.