Can't mout /image folder and /images folder



  • Hi,
    i test a "Quick image ", but when fog start the proces return “can’t Mount image and images folder”,
    i see the directory but have not the seme owner (www-fog).
    how can reset or adjust the correct value in fog settings ??

    i have deleted the “images” folder default and create the “image” folder but have not the same owner of the other folder ( i can’t change the fog user with sudo because the not known the password … )



  • yes the exports files is ok.
    now the task start but when display " … prepare device … " , waiting…
    when i press “enter” , dispay " invalid partition data" and reboot

    . i setting “other windows image not resizable” because if setting “windows 7 system” fog return when start-up , boot sector not found !


  • Senior Developer

    Did you add the /image and /image/dev export to your
    /etc/exports file?



  • Hi, the directory /images exist ,
    your command not returned error

    i change parameter of directory ( 777 fog:fog ) and setting /images in GUI menu fog server

    the system return the message :

    mount: mounting xxx.xxx.xxx.xxx:/image on /images failed , permission denied


  • Senior Developer

    The owner ship shouldn’t matter as the entirety of the /image (or /images) folders should be chmodded to 777 (Anyone full read,write,exectue)

    What I think is missing is the .mntcheck files

    [code]sudo touch /image/.mntcheck;
    sudo touch /image/dev/.mntcheck;
    sudo chmod -R 777 /image[/code]


Log in to reply
 

371
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.