Hirens Boot CD 15.2 Hangs with "Loading boot sector... booting..."



  • Hello all!

    I’ve decided to start delving into the advanced menu options of fog and noticed that as of FOG 1.x.x it has changed to use iPXE style commands as opposed to the classic pxelinux.0 style commands. So after a bit of research and coming up with threads/help pages written by the wonderful people here such as -

    [URL=‘http://fogproject.org/forum/threads/ipxe-advanced-menu-or-memdisk-problem.10544/’]http://www.fogproject.org/wiki/index.php/Advanced_Boot_Menu_Configuration_options/[/URL]
    [URL=‘http://’]http://fogproject.org/forum/threads/ipxe-advanced-menu-or-memdisk-problem.10544/[/URL]

    • I decided to give it a go. For the most part it does work (initiates/downloads the ISO as a ramdisk and memdisk starts doing its thing) but this is where it stops… at the line “Loading boot sector… booting…”

    At this point I had thought that it was just that hirens didn’t work anymore, but then I found this thread -

    [url]http://fogproject.org/forum/threads/ipxe-iso-boot-problems.10929/#post-31316[/url]

    • and if it works in that situation then realistically it should work here too!

    I am also able to browse to the location on the fog server and get a download of the hirens.iso so I know it’s not a path issue at this point.


    Here is my advanced menu config (which matches the one in the last link regarding the ISO/memdisk parts):

    [QUOTE]

    set boot-url [url]http://${fog-ip}/${fog-webroot}[/url]
    :MENU
    menu
    item hirens Hirens Tools
    item hostinfo HOST Information (Your MACHINE Info)
    item return return to previous menu
    choose target && goto ${target} || goto MENU

    :hirens
    initrd ${boot-url}/ISO/hirens.iso
    chain memdisk iso raw ||
    echo failed to boot
    prompt
    goto MENU

    :hostinfo
    echo This computer : ||
    echo MAC address…${net0/mac} ||
    echo IP address…${ip} ||
    echo Netmask…${netmask} ||
    echo Serial…${serial} ||
    echo Asset number…${asset} ||
    echo Manufacturer…${manufacturer} ||
    echo Product…${product} ||
    echo BIOS platform…${platform} ||
    echo ||
    echo press any key to return to Menu ||
    prompt
    goto MENU

    :return
    chain ${boot-url}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU

    [/QUOTE]

    I suppose that I should mention that my setup is a little non-standard in that I have a secondary drive for all images, and the main one is only big enough for the OS. So I have the hirens.iso on the second drive (which is mounted on /images) in a folder called BOOT, which is then symlinked to the folder /var/www/fog/ISO/. Not sure if symlinks could cause this kind of issue, but I figured mentioning wouldn’t hurt.

    Thank you everyone for any help!



  • UPDATE! It works!

    Turns out the issue was all of my ISOs after all. Somewhere along the line of transferring them via ftp from my windows IIS server the data ended up being cut off; which I assume is why the “MEMDISK: Image appears to be truncated” message was there.

    This is what happens when I try to cut corners on a terminal-only linux box… :(

    Thank you for your help, and sorry to be a bother.



  • So I copied your menu item settings exactly and it’s still happening…

    There’s a few new lines this time. The rest appears to be the same as above

    [CODE]El Torito boot catalog sanity check failed.

    MEMDISK: Image appears to be truncated[/CODE]

    Maybe the sanity check thing is the key? I’m not sure what it means but I’ll be researching it while this post is up.


  • Senior Developer

    I’ve downloaded a copy of Hirens Boot CD 15.2 and created a menu entry for it.

    My exact settings are:

    [code]
    :hirens
    initrd http://${fog-ip}/iso/hirensbootcd.iso
    chain memdisk iso raw[/code]

    I’m not having any issues.



  • Yeah, I ended up following this guide to put it on a USB stick and that worked fine. This is also the same ISO that I have used in the past as an actual bootable DVD. [url]http://www.hiren.info/pages/bootcd-on-usb-disk[/url]

    I don’t think I’ve ever encountered a machine that wouldn’t boot this ISO on USB/DVD in a way like was described in the link you posted.

    Also after your last reply I thought I should try some other ISOs to rule it out as an issue with the hirens.iso so I grabbed an old copy I had of TinyCore, Slitaz, and DSL Linux; I tried those and they resulted in similar, the only difference being that one more line was added to the output I posted above.

    [QUOTE]ISOLINUX X.XX yyyy-mm-dd[/QUOTE]

    Where the placeholders are the version, and date of release of ISOLINUX


  • Senior Developer

    [url]http://reboot.pro/topic/16216-hirens-boot-151usb-troubles/[/url]

    Have you tried booting this on another system?



  • After doing that the end results are the same, unfortunately.
    The client is still able to download the ISO and start memdisk using the ISO as a ramdisk.

    I changed the memdisk line to the below as described;
    [CODE]:hirens
    initrd ${boot-url}/ISO/hirens.iso
    chain memdisk ||
    echo failed to boot
    prompt
    goto MENU[/CODE]

    And this is the output on the clients screen is;
    [CODE]Ramdisk at 0x1abf8000, length 0x252f71ba
    command line:
    MEMDISK: Image has fractional end sector
    MEMDISK: Image seems to have fractional end cylinder
    Disk is hd0, 609244 K, C/H/S = 594/64/32 (guess/guess), EDD on, rw
    Using safe INT15h access to high memory
    Code 1744, meminfo 264, cmdline 1, stack 512
    Total size needed = 2521 bytes, allocating 3K
    Old dos memory at 0x94c00 (map says 0x94c00), loading at 0x94000
    1588: 0xffff 15E801: 0x3c00 0x19bf
    INT 13 08: Success, count = 2, BPT= 0000:0000
    Drive probing gives drive shift limit: 0x83
    old: int13 = 94x0000a int15 = 94c003ba int1e = f00082ad
    new: int13 = 9400000a int15 = 940003ba int1e = f00082ad
    Loading boot sector… booting…[/CODE]

    Looks like there is a section referring to the integrity of the ISO right after the command line. Is that normal when booting ISOs?


  • Senior Developer

    Could you try removing the raw and iso part from the memdisk line?


Log in to reply
 

352
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.