[SOLVED] ipxe(1c1c2002) Invalid argument



  • Hey,

    I have a Fog server that is running on Centos 6.5 (NEW INSTALL) + FOG 1.2.0 (NEW INSTALL) on a real machine however the server is not the isseu I am having, I am having an issue with “ipxe(1c1c2002) Invalid argument” just after the bg.png file is loaded as you can see in the img below and then I get the error about ipxe.
    [CENTER][IMG]http://i.imgur.com/5vglPIS.jpg[/IMG][/CENTER]
    [CENTER][B]BOX INFO:[/B] 2GB RAM | P4 PROX | Dell gx260[/CENTER]
    [CENTER] [/CENTER]
    [LEFT]This error is only on the Dell gx260’s and I have 24 of the pc’s that need to have an OS installed with in 2 weeks and I really don’t wanna do it all by hand lol, HOWEVER! like I was saying its only the gx260’s having this issue if I boot up a vm from my server and PXE boot it has no issue getting to the menu at all as seen blow.[/LEFT]
    [CENTER][IMG]http://i.imgur.com/NjYSbSS.png[/IMG][/CENTER]
    [LEFT] [/LEFT]
    [LEFT] [/LEFT]
    [CENTER]How can we get this error fixed and I can get to installing the OS on the box’z???[/CENTER]
    [CENTER] [/CENTER]
    [CENTER]NOTE: I have pfsense as a firewall for my network and I have set the settings for the PXE and so on.[/CENTER]
    [CENTER][IMG]http://i.imgur.com/hfFU1XL.png[/IMG]Thanks :)[/CENTER]



  • YES!!! Thanks Tom you tha man!!! ;) I was going to edit the file but after looking into it I was like nope nope nope lol so I did the upgrade and it worked.

    [CENTER][IMG]http://i.imgur.com/tkDg8Is.png[/IMG][/CENTER]

    [solved]
    By upgrade to svn:[url]http://fogproject.org/wiki/index.php/Upgrade_to_trunk[/url]


  • Senior Developer

    Looks like Line #684

    Here’s the link to upgrade to svn:
    [url]http://fogproject.org/wiki/index.php/Upgrade_to_trunk[/url]



  • Hi Tom,

    Thanks for getting back to me so fast & what do you mean by “upgrade to the SVN” ? link to some more info would be nice do to I have been reading over the forum and I have been seeing this here and there.

    I will give the editing /var/www/fog/lib/fog/BootMenu.class.php a try and see what happens but before I do so do so would you happen to have a line(s) # I am looking for?

    Thanks :)


  • Senior Developer

    This is a known issue with some systems.

    If you want, you can upgrade to the SVN which should have this fixed for you.

    Otherwise, if you want those and all systems to still work, the simplest would be to edit the /var/www/fog/lib/fog/BootMenu.class.php file. Look for the line that deals with console and comment it out.

    It won’t be pretty but it should work for your needs.


Log in to reply
 

443
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.