Blank Image Creation error - An operating system is requried



  • I am using FOG 1.2.0 and trying to create a new blank image of Windows 7 64 bit OS through Image Management. After filling all information i clicked on ADD button and get the message/error "An Operating System is required ".

    Please tell where to add/assign the Operating System to the image.

    Thanks
    Sher



  • solved the problem by recreating these 5 tables with myisam engine and filling the records from old mysql dump.



  • I have checked the FOG database tables in phymyadmin and found out that there are five tables which are not accessible. On clicking on them phpmyadmin displays the error " #1286 Unknown storage engine ‘innodb’ ".
    The tables are:

    1. modules
    2. os
    3. tasklog
    4. taskstats
    5. tasktypes

    ‘innodb’ engine is disabled in mysql database.

    Please guide what should i do.
    Should i enable innodb engine ? or
    Is it possible to convert the five tables to MyISAM format.

    Thanks
    Sher



  • On my Ubuntu 14.04 LTS desktop, I upgraded FOG from version 1.2.0 to 1.3.0. The FOG was upgraded successfully without any warnings.

    If there is a database issue how can i figure that out ?

    Please refer to my FOG installation log as per follows :

    Ubuntu

       ..#######:.    ..,#,..     .::##::.   
    

    .:###### .:;####:…;#;…
    …##… …##;,;##::::.##…
    ,# …##…##:::## …::
    ## .::###,##. . ##.::#.:######::.
    …##:::###::…#. … .#…#. #…#:::.
    …:####:… …##…##::## … #
    # . …##:,;##;:::#: … ##…
    .# . .:;####;::::.##:::;#:…
    # …:;###…

    ###########################################

    FOG

    Free Computer Imaging Solution

    [url]http://www.fogproject.org/[/url]

    Developers:

    Chuck Syperski

    Jian Zhang

    Peter Gilchrist

    Tom Elliott

    GNU GPL Version 3

    ###########################################

    Version: 1.3.0 Installer/Updater

    • Found FOG Settings from previous install at: /opt/fog/.fogsettings
    • Performing upgrade using these settings…

    Starting Debian / Ubuntu / Kubuntu / Edubuntu Installtion.

    #####################################################################

    FOG now has everything it needs to setup your server, but please
    understand that this script will overwrite any setting you may
    have setup for services like DHCP, apache, pxe, tftp, and NFS.

    It is not recommended that you install this on a production system
    as this script modifies many of your system settings.

    This script should be run by the root user on Redhat or with sudo on Ubuntu.

    ** Notice ** Redhat users will need to disable SELinux and iptables in
    order to use FOG
    Please see our wiki for more information at [url]http://www.fogproject.org/wiki[/url]

    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 172.16.0.31
    DHCP router Address: 172.16.0.6
    DHCP DNS Address: 8.8.8.8
    Interface: eth0
    Using FOG DHCP: 1
    Internationalization: 0
    Image Storage Location: /images
    Donate: 0

    Are you sure you wish to continue (Y/N)
    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Packages to be installed: apache2 php5 php5-json php5-gd php5-cli php5-mysql php5-curl mysql-server mysql-client isc-dhcp-server tftpd-hpa tftp-hpa nfs-kernel-server vsftpd net-tools wget xinetd sysv-rc-conf tar gzip build-essential cpp gcc g++ m4 htmldoc lftp openssh-server php-gettext

    • Skipping package: apache2 (Already installed)

    • Skipping package: php5 (Already installed)

    • Skipping package: php5-json (Already installed)

    • Skipping package: php5-gd (Already installed)

    • Skipping package: php5-cli (Already installed)

    • Skipping package: php5-mysql (Already installed)

    • Skipping package: php5-curl (Already installed)

    • Skipping package: mysql-server (Already installed)

    • Skipping package: mysql-client (Already installed)

    • Skipping package: isc-dhcp-server (Already installed)

    • Skipping package: tftpd-hpa (Already installed)

    • Skipping package: tftp-hpa (Already installed)

    • Skipping package: nfs-kernel-server (Already installed)

    • Skipping package: vsftpd (Already installed)

    • Skipping package: net-tools (Already installed)

    • Skipping package: wget (Already installed)

    • Skipping package: xinetd (Already installed)

    • Skipping package: sysv-rc-conf (Already installed)

    • Skipping package: tar (Already installed)

    • Skipping package: gzip (Already installed)

    • Skipping package: build-essential (Already installed)

    • Skipping package: cpp (Already installed)

    • Skipping package: gcc (Already installed)

    • Skipping package: g++ (Already installed)

    • Skipping package: m4 (Already installed)

    • Skipping package: htmldoc (Already installed)

    • Skipping package: lftp (Already installed)

    • Skipping package: openssh-server (Already installed)

    • Skipping package: php-gettext (Already installed)

    Confirming package installation.

    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-json…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-mysql…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: isc-dhcp-server…OK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK

    Configuring services.

    • Setting up and starting MySql…OK

    • Backing up user reports…OK

    • Setting up and starting Apache Web Server…OK

    • Copying back any custom hook files.

    • Copying back any custom report files.
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:

      [url]http://172.16.0.31/fog/management[/url]

    Press [Enter] key when database is updated/installed.

    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Setting up FOG Utils…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…OK
    • Starting FOG Task Scheduler Server…OK
    • Starting FOG Snapin Replicator Server…OK
    • Configuring Fresh Clam…OK

    Setup complete!

    You can now login to the FOG Management Portal using
    the information listed below. The login information
    is only if this is the first install.

    This can be done by opening a web browser and going to:

      [url]http://172.16.0.31/fog/management[/url]
    
      Default User:
             Username: fog
             Password: password
    

    thanks


  • Senior Developer

    Sounds to me like your database didn’t update properly. Did you copy database over from another database after the schema update had happened?



  • Most odd, I’ve been using Fog for about 6 years now and have never seen anything like that. Perhaps something went wrong when the database schema was being set up ?

    I’d try a reinstall. Failing that over to one of the clever people on the forum :(

    Cheers
    Robin



  • Dear Robin,
    I tried. There is Operating System option but no drop down list for it. You can check from the screen shot attached herewith.

    thanks

    [url="/_imported_xf_attachments/1/1527_screenshot.png?:"]screenshot.png[/url]



  • Hi Sher,

    Go to Image Management > Create New Image and you’ll see the fields that you need to set. In there there is one called Operating system where you click on the dropdown and set the type appropriately. For Windows 7 (irrespective of 32 or 64 bit) you’ll need to set this to type 5.

    HTH

    Cheers
    Robin


Log in to reply
 

420
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.