Live CD Configurations for boot



  • Well, I am sure this has been asked and answered for many however, I cannot find a usable solution online from any resources so far in attempt to get multiple live CD’s to boot from the fog server i have set up.

    Firstly, if there is some hidden tutorial i have not read yet, please do post a link for me.

    Fog server is the newest version currently available ( 1.2 ) and the live cd I am trying to boot first is the Ubuntu 14.04 64 bit desktop ISO.

    Successes so far…
    Loading the iso into memory using a similar script added to the advanced PXE boot options

    item UBUNTU Ubuntu 14.04 64b
     
    :UBUNTU
    initrd http://${fog-ip}/fog/service/ipxe/iso/ubuntu-14.04-64.iso
    chain memdisk iso raw ||
    echo failed to boot
    prompt
    goto MENU
    

    I did not post the entirety of this menu, only the relevant pieces.
    This loads the ISO file, and continues to the boot loading process. Ubuntu loading screen appears as expected.
    Fails to boot after a minute, giving me a command line .

    (initramfs)

    where the username usually is. And I can type commands. list the directory etc. but cannot CD into certain directories.

    I have tried this with other liveCD’s and each encounter an error after the text based screens. Kav-rescue cd got the furthest, with me able to select between GUI and text based modes, but will fail on GUI selection (have not tried text based, though it being not my preference I would assume that would go along without a hitch =P )

    If anyone has a working liveCD boot configuration on their FOG server, or know how to create one, any help would be appreciated.
    I have tried using NFS with the kernel options but I am either not setting this up properly ( most likely as i am lost on some of those instructions ) or it is simply an outdated solution. I’m not sure which, but i have not gotten as far as I have with utilizing the ISO file itself.



  • @Tom Elliott, post: 39810, member: 7271 said:

    Also,

    Maybe try:

    >:CLONELIVECD
    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso
    chain memdisk
    >```
     
     
    This works!   It appears that memdisk ISO is not necessary and causes the squashfs errors.   I have tested this on clonezilla livecd and parted magic livecd so far and will report back if run into problems with other livecds. 
     
    Thanks for your help and I hope others find this information.


  • http://fogproject.org/forum/threads/live-cd-configurations-for-boot.12044/#post-39769

    And the fact it’s complaining about the missing initramfs, what about:

    :CLONELIVECD
    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso
    chain memdisk iso raw initrd=initrd.lz
    ```[/quote]
     
     
    Sorry for the delay in making it back here.  I only have time to experiment with this infrequently.
     
    The above code produces the same squashfs and BusyBox v1.22.1 Boot Failed! error.

  • Senior Developer

    Also,

    Maybe try:

    :CLONELIVECD
    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso
    chain memdisk
    

  • Senior Developer

    http://fogproject.org/forum/threads/live-cd-configurations-for-boot.12044/#post-39769

    And the fact it’s complaining about the missing initramfs, what about:

    :CLONELIVECD
    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso
    chain memdisk iso raw initrd=initrd.lz
    


  • finally i get a working config:

    :UBUNTU

    See http://manpages.ubuntu.com/manpages/precise/man7/casper.7.html for casper cmdline details

    kernel http://192.168.0.3/fog/iso/ubuntu/casper/vmlinuz
    initrd http://192.168.0.3/fog/iso/ubuntu/casper/initrd.lz
    imgargs vmlinuz root=/dev/nfs boot=casper netboot=nfs nfsroot=192.168.0.3:/var/www/fog/iso/ubuntu/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=no mirror/country=NO
    boot || goto failed
    goto start

    $ cat /etc/exports
    /images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)
    /var/www/fog/iso/ubuntu/ *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)

    administrator@fog:/var/www/fog/iso/ubuntu$ ls -la
    totale 32
    dr-xr-xr-x 5 root root 4096 dic 5 12:48 .
    drwxr-xr-x 3 root root 4096 dic 5 12:47 …
    dr-xr-xr-x 3 root root 4096 dic 9 08:37 casper
    dr-xr-xr-x 2 root root 4096 ago 9 22:19 .disk
    dr-xr-xr-x 2 root root 4096 ago 9 22:19 isolinux
    -r-xr-xr-x 1 root root 8351 ago 9 22:20 SHA256SUMS
    administrator@fog:/var/www/fog/iso/ubuntu$



  • http://forum.ipxe.org/showthread.php?tid=6879

    initrd http://192.168.xxx.xxx:port/mxp14.iso
    chain memdisk iso

    Notice the lack of “raw” at the end? Maybe this will help?

    :UBUNTU
    initrd http://${fog-ip}/fog/service/ipxe/iso/ubuntu-14.04-64.iso
    chain memdisk iso ||
    echo failed to boot
    prompt
    goto MENU
    ```[/quote]
     
    with this configuration i get:
     
    BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
    Enter 'help' for a list of built-in commands
    (intrafms) Unable to find a medium containing a live file system


  • http://forum.ipxe.org/showthread.php?tid=6879

    initrd http://192.168.xxx.xxx:port/mxp14.iso
    chain memdisk iso

    Notice the lack of “raw” at the end? Maybe this will help?

    :UBUNTU
    initrd http://${fog-ip}/fog/service/ipxe/iso/ubuntu-14.04-64.iso
    chain memdisk iso ||
    echo failed to boot
    prompt
    goto MENU
    ```[/quote]
     
    

    :CLONELIVECD
    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso
    chain memdisk iso ||
    goto MENU

     
    This boots but produces the same squashfs error and a Boot Failed! message ending at an initramfs BusyBox v1.22.1 shell prompt.


  • http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso iso raw[/quote]

    This loads the iso via http but never executes it, returning to the advanced pxe menu


  • Senior Developer

    http://${fog-ip}/fog/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/iso/clonezilla/initrd.img
    imgargs vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_keymap="" ocs_live_batch=“no” ocs_daemonon=“ssh” usercrypted=Kb/VNchPYhuf6 ocs_lang="" vga=788 nosplash noprompt fetch=http://${fog-ip}/fog/iso/clonezilla/filesystem.squashfs
    boot ||

    The above boots a working clonezilla, though not identical to the livecd. This does not seem an improvement over the simple livecd booting method under the old pxelinux menu:

    LABEL clonezilla
    MENU LABEL Clonezilla Live
    LINUX clonezilla/memdisk
    APPEND iso initrd=/clonezilla/clonezilla.iso raw

    I’m finding the new ipxe boot menu means extracting files and updating a custom set of imgargs for every livecd. I’m no linux expert and I’m finding the correct imgargs to work with ipxe a challenge and testing a largely trial and error exercise for each livecd.

    I wonder if there is a way to boot pxelinux from ipxe so that the old menu system could be used?[/quote]

    Just because it was harder, doesn’t not mean that it’s worse.

    While I understand the frustration, the whole reasoning to move to ipxe was to gain access to http downloading vs. tftp. Http gains access to full spectrum bandwidth capabilities of your network. Tftp was always extremely slow, like limited to 10Mbps.

    There’s so many resources out there, yet everybody seems to think that the FOG Team must be doing something to make your lives harder.

    I Assure you all, that this is not the case, nor has it ever been. If anything, the reason for all the changes was due to requests from all of you before.


  • Senior Developer

    According to this: http://forum.ipxe.org/showthread.php?tid=6879

    initrd http://192.168.xxx.xxx:port/mxp14.iso
    chain memdisk iso

    Notice the lack of “raw” at the end? Maybe this will help?

    :UBUNTU
    initrd http://${fog-ip}/fog/service/ipxe/iso/ubuntu-14.04-64.iso
    chain memdisk iso ||
    echo failed to boot
    prompt
    goto MENU
    

  • Senior Developer

    Have you, possibly, tried using:

    initrd http://${fog-ip}/fog/iso/clonezilla/clonezilla.iso iso raw



  • I really miss the old simple pxelinux menu and the ability to easily boot livecds using memdisk iso raw. It was a really simple way to have a an easily managed menu of bootable utility cds that boot directly into the live environment through tftp. If I wanted to upgrade a live version, all I had to do was replace the iso file. It just worked to boot livecds on every machine I have.

    Upgraded to 1.2 with ipxe and maintaining a boot menu with the advanced menu became a lot more complicated. Trying to use memdisk iso raw with clonezilla livecd doesn’t work anymore because it can’t find the filesystem.squashfs. I had to extract the files from the livecd and use the following advanced boot menu code:

    :CLONEZILLA
    kernel http://${fog-ip}/fog/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/fog/iso/clonezilla/initrd.img
    imgargs vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_keymap="" ocs_live_batch=“no” ocs_daemonon=“ssh” usercrypted=Kb/VNchPYhuf6 ocs_lang="" vga=788 nosplash noprompt fetch=http://${fog-ip}/fog/iso/clonezilla/filesystem.squashfs
    boot ||

    The above boots a working clonezilla, though not identical to the livecd. This does not seem an improvement over the simple livecd booting method under the old pxelinux menu:

    LABEL clonezilla
    MENU LABEL Clonezilla Live
    LINUX clonezilla/memdisk
    APPEND iso initrd=/clonezilla/clonezilla.iso raw

    I’m finding the new ipxe boot menu means extracting files and updating a custom set of imgargs for every livecd. I’m no linux expert and I’m finding the correct imgargs to work with ipxe a challenge and testing a largely trial and error exercise for each livecd.

    I wonder if there is a way to boot pxelinux from ipxe so that the old menu system could be used?



  • i tryed also

    :UBUNTU
    kernel http://${fog-ip}/fog/iso/ubuntu/casper/vmlinuz
    initrd http://${fog-ip}/fog/iso/ubuntu/casper/initrd.lz
    imgargs vmlinuz root=/dev/nfs boot=. netboot=nfs nfsroot=192.168.0.3:/var/www/fog/iso/ubuntu/casper/ locale=it_IT console-setup/layoutcode=no
    boot || goto failed
    goto MENU

    using nfs and the kernel boots up after that, (intramfs) is printed on screen


  • Senior Developer

    How isn’t it working?

    I need more details.

    Have you at least extracted these files to that location so they’re actually accessible?

    Just because there’s a problem does not mean it’s automatically FOG’s doing. There are some tasks that need to be done by the user.



  • i tryed also this version, that don’t work:

    :UBUNTU
    kernel http://${fog-ip}/fog/iso/ubuntu/casper/vmlinuz
    initrd http://${fog-ip}/fog/iso/ubuntu/casper/initrd.lz
    imgargs vmlinuz boot=live config console=ttyS0 username=live fetch=http://${fog-ip}/fog/iso/ubuntu/casper/filesystem.squashfs
    boot || goto failed
    goto MENU



  • I have tried another version of loading the files to clinet machine through the PXE advanced options.

    :UBUNTU
    kernel http://${fog-ip}/fog/service/ipxe/boot/ubu1/casper/vmlinuz
    initrd http://${fog-ip}/fog/service/ipxe/boot/ubu1/casper/initrd.lz
    boot 
    

    In this case, the code above essentially gets me to the same screen as before.
    It seemingly has booted into … something. Giving me the (initramfs) _ line not unlike what the terminal looks in ubuntu. I am missing some step here in which certain files necessary to the boot process of the live CD have been left out, or rather, not pointed to. I am looking to find out what I am missing, and how to remedy this issue. As I intend to try other live CDs it will be important to understand what files are necesssary in a debian type OS


Log in to reply
 

370
Online

38724
Users

10553
Topics

99875
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.