Boot.php permissiondenied



  • Hi!

    I run FOG on Debian and encounter this strange problem:
    Clients boots by TFTP then it reads:
    "boot.php permission denied"
    then client reboots.
    i checked any file permissions, they look great.
    Does anyone have this issue too?
    regards!



  • Hey, konw I know lots more about fog than i used to know, and i use it since 0.30 or so ;)


  • Senior Developer

    No problem and glad to be of some kind of assistance. The folder should be owned by fog and www-data/apache. This is specific to allow kernel updates to work properly.



  • I Found it!
    *** OUCH ***
    The apache-log revealed it: HTTP 401 is the problem. 401 -> user authorization required!!!
    /var/www was protected by .htaccess sigh

    I am really sorry to have bothered you with this, on the other hand: I would have had no chance to figure it out without your hint to check the apache-log ;)

    THANKS A LOT !!!
    Best regards!
    Xibeaga



  • Okay, i did. no change to the behaviour.

    I recognized that dir ipxe is not owned by “www-data” but by “fog”, the contents of ipxe are also owned by "fog"
    everything else is owned by “www-data” it seems.

    And YES this appears on all clients, also with different hardware

    How i generated the logfile:

    1. I stopped apache
    2. i deleted all logs
    3. i launched apache
    4. i pxebooted a client
    5. stopped apache
      Unfortunately ther is exactly 1 line in the logfile:

    172.16.3.51 - - [27/Nov/2014:22:15:43 +0100] “POST /fog/service/ipxe/boot.php HTTP/1.1” 401 722 “-” “iPXE/1.0.0+ (3a02)”


  • Senior Developer

    Well the good news is its not really the boot.php that’s having the error but I’m not sure where the boot script is failing.

    Can you set the permissions for the while service ipxe folder? Maybe: [code]chmod -R 777 /var/www/fog/service/ipxe[/code]

    Also can you give us your Apache error log directly after this occurs? Also is thus happening on all systems.



  • Okay, here is a screenshot, maybe this helps.

    [url="/_imported_xf_attachments/1/1524_fogerror.png?:"]fogerror.png[/url]


  • Senior Developer

    I’m under the impression something else is going on.

    Is the ONLY error a Permission denied on the boot.php, or are there (even a flash) of a few more lines? Maybe something along the lines of Console error or what not?



  • this: IP looks fine

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [url]http://172.16.3.93/fog/service/ipxe/boot.php##params[/url]


  • Developer

    what is the contents of your default.ipxe file? have you changed the IP of the server since you installed?



  • yes. It all runs fine until boot.php


  • Senior Developer

    Is next server pointing at the proper server?



  • Hm, no, I only use next-server-option at my DHCP, everything else does not have any redirections.


  • Senior Developer

    I am only working off of theory here:

    You have a redirect somewhere? Maybe you’re trying to go: hostnameoffog without actually go to hostnameoffog/fog

    What’s happening (in my theory) is the file is searching for:

    hostnameoffog/fog/service/ipxe/boot.php

    But because of the redirect, it’s trying to go to file:

    hostnameoffog/service/ipxe/boot.php

    Because hostnameoffog/service/ipxe/boot.php doesn’t exist, it’s not able to find it, hence permission denied.



  • okay, i did.
    now install runs clean (including correct UDP cast)

    but when i try to pxeboot a client: boot.php permission denied
    the fog boot-menu never show up


  • Senior Developer

    [quote=“Xibeaga, post: 39347, member: 982”]tmpfs /tmp tmpfs defaults,noexec,nosuid,size=10485760 0 0[/quote]

    Remove the ,noexec and restart your system.

    Then try rerunning the installer.



  • tmpfs /tmp tmpfs defaults,noexec,nosuid,size=10485760 0 0


  • Senior Developer

    What’s in the /etc/fstab for the /tmp?



  • Yes, it reads:
    drwxrwxrwt /tmp


  • Senior Developer

    Is your /tmp folder allowed to execute files?


Log in to reply
 

479
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.