Problems with advanced pxe menu



  • Hi¡¡¡

    I try to modify my advanced pxe menú. I wish bypass host registration because in this moment I don´t need registration the computers. I read the wiki for this topic, but this is for fog 0.32 and I have fog 1.2.0

    This is my advanced menú.

    :MENU
    menu
    item --gap Choose the image
    item fog.local Boot from hard disk
    item 360 Optiplex360
    item return Return to main menu
    choose --default fog.local target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :360
    kernel bzImage
    initrd [url]http://10.2.21.110/fog/service/ipxe/noreg.gz[/url]
    root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.2.20.5 web=10.2.21.110/fog/ consoleblank=0 loglevel=4 type=down img=optiplex360 ftp=10.2.21.110 imgType=mps osid=1 storage=10.2.21.110:/images/ capone=1 imgFormat=1
    imgfetch init.xz
    boot || goto MENU
    :return
    chain [url]http://10.2.21.110}/fog-webroot/service/ipxe/boot.php?mac=${net0/mac[/url]} || goto MENU
    autoboot

    The computer try to boot but this restart always.

    Could you help me please?

    Thank You.



  • I reinstall the SVN version and now fog server work properly.
    Thank you Tom, great job¡¡
    Bye.



  • I dont´have multiple nodes and actually fog running in SVN version.
    /images is mounted in local disk and my firewall is disabled. Before upgrade to SVN version I can deploy image and upload
    image but the host need registration in fog server.
    Do you need any log for help me?
    Thank you very much.


  • Senior Developer

    I don’t have any information or knowledge of your particular setup.

    Do you have multiple nodes?

    Are you running SVN version of fog now?

    If you can’t upload an image, it’s likely an nfs server issue, but my next question is:

    How is /images mounted on your server? Is it mounted via another NFS share? Is it a local disk? Also, are you sure firewall/selinux are disabled on your system?



  • Thank You Tom,
    I upgrade to SVN and now appear in the Quick Image section my images, but when I try to deploy this appear an error of permission denied. I try to upload an image from computer to fog then appear an error of mount failed. I review the permission of images folder but it is correct.
    Could you help me please?


  • Senior Developer

    If you can upgrade to SVN, you will not need this any more.

    Just choose Quick Image, sign in with the FOG GUI credentials, and select the image you want to use.


Log in to reply
 

366
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.