Upgrade Problems



  • Upgrading from 0.32 to 1.2.0 on Ubuntu 10.04 LTS. This used to be a physical machine and about two years ago I converted it to a VM. I believe my first issue is due to the conversion. Anyways when upgrading it says… “You still need to install/update your database schema. This can be done by opening a web browser and going to: XXX.XXX.XXX.XXX” Anyways that IP address is still the old one. Issue #2. When I go to the current IP Address/fog/management it brings up the Database Schema Installer / Updater. When I go to upgrade it fails with a huge report. Any insight as to what is happening and how to fix is greatly appreciated! Thanks!



  • After re-storing my server back to a working state I tried changing all the files mentioned. I still get the same error. Does it make a difference if I am on SQL 5.1 vs 5.5?



  • I forgot to mention that you need to update your password in here too:

    /var/www/fog/lib/fog/Config.class.php

    Then: [CODE]service mysql restart[/CODE]

    Make sure FOG works normally. Then try to upgrade again.



  • It is running, process 12432. Still no luck. Thanks!


  • Senior Developer

    Ensure mysql service is actually running:

    From another terminal run:
    [code]sudo service mysql restart[/code]



  • So what I do is go to the Fog_1.2.0/bin run ./installfog.sh The install starts, I accept the DHCP information with Y. I get a message saying “We are about to install MySQL Server on this server, if MySQL isn’t installed already you will be prompted for a root password.” “Press enter to acknowledge this message.” So I press enter. Then it tells me to open my browser to install/update your database schema. So I go into the browser to do that and that is when it tells me it failed.

    [url="/_imported_xf_attachments/1/1454_FogError.pdf?:"]FogError.pdf[/url]


  • Senior Developer

    That’s what you do when you make a change in fogsettings
    fog settings just makes it an “upgrade”

    You go back to your “install” folder
    and run
    ./installfog.sh

    It takes care of the rest.



  • I do not believe I have ever re-installed fog.


  • Senior Developer

    did you reinstall fog?



  • Im on Sql 5.1 if that matters, but I did change the password for SQL and in the .fogsettings with no luck.

    Thanks!



  • I had this same issue when I upgraded to 1.2.0. I had to run [CODE]dpkg-reconfigure mysql-server-5.5[/CODE] to change my root password for MySQL. I then updated the password in .fogsettings and it worked.



  • My apologies, I restarted my Fog server.


  • Senior Developer

    What do you mean restarted in the browser?



  • I edited .fogsettings per your recommendation. I tried to re-run and it failed, I restarted it still failed, I cleared the cache in the browser just to be safe and it still failed. I am sorry for the bad news. Thanks!


  • Senior Developer

    When you edit .fogsettings, it doesn’t automatically transfer over, it just makes your upgrading much easier.

    If you can re-run the installer, all should work for you.



  • Thank you Tom for you reply. I was able to fix my first issue with the ip address being wrong within the .fogsettings file. As far as my second issue I am still having problems, even after entering the fields you stated. Other thoughts?

    Thanks!


  • Senior Developer

    Edit the /opt/fog/.fogsettings file

    Particularly the fields:

    snmysqluser
    snmysqlhost
    snmysqlpass

    snmysqluser should be:

    snmysqluser=“root”;
    snmysqlhost=“IP.OF.FOG.XX”;
    snmysqlpass=“passwordofsqlrootuser”;



  • I do have a password set for mysql. I have not seen any place for me to type the password during the upgrade though. Thanks!



  • Do you have set an mysql password during installation of fog? It could be that the mysql password in fog is not correct and then it fails in updating.


Log in to reply
 

411
Online

39210
Users

10856
Topics

103343
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.